# CVE-2025-49824: conda-smithy Insecure Encryption Vulnerable to Oracle Padding Attack

> An attacker with oracle access can decrypt sensitive tokens in conda-smithy due to insecure RSA padding, exposing private keys.

- **Severity:** Low 1.7 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 17 Jun 2025
- **Updated:** 18 Jun 2025
- **Also known as:** GHSA-2xf4-hg9q-m58q

## What is CVE-2025-49824?

CVE-2025-49824 is a low-severity vulnerability in conda-forge conda-smithy, published on 17 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

conda-smithy is a tool for combining a conda recipe with configurations to build using freely hosted CI services into a single repository. Prior to version 3.47.1, the travis_encrypt_binstar_token implementation in the conda-smithy package has been identified as vulnerable to an Oracle Padding Attack. This vulnerability results from the use of an outdated and insecure padding scheme during RSA encryption. A malicious actor with access to an oracle system can exploit this flaw by iteratively submitting modified ciphertexts and analyzing responses to infer the plaintext without possessing the private key. This issue has been patched in version 3.47.1.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2025-49824?


## How do I fix CVE-2025-49824?

No fix has been published for CVE-2025-49824 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-49824 being exploited?

There is no known exploitation of CVE-2025-49824 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-49824 and fix it if it is affected.

What it is: CVE-2025-49824 is a low-severity vulnerability in conda-forge conda-smithy, published on 17 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-49824 in the wild and no public exploit code.

Affected product: conda-forge conda-smithy. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-49824/ (Markdown: https://insights.sbomify.com/CVE-2025-49824/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-49824
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-49824
- OSV: https://osv.dev/vulnerability/CVE-2025-49824

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-49824/
Summaries are generated and may contain mistakes; the official description above is the record.
