# CVE-2025-49825: Teleport allows remote authentication bypass

> Remote attackers can bypass authentication in Teleport Community Edition, gaining unauthorized access to infrastructure without valid credentials.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jun 2025
- **Updated:** 18 Jun 2025
- **Also known as:** GHSA-8cqv-pj7f-pwpc, GO-2025-3763, openSUSE-SU-2025:15300-1

## What is CVE-2025-49825?

CVE-2025-49825 is a critical authentication bypass vulnerability in gravitational teleport, published on 17 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Teleport provides connectivity, authentication, access controls and audit for infrastructure. Community Edition versions before and including 17.5.1 are vulnerable to remote authentication bypass. At time of posting, there is no available open-source patch.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2025-49825?

16 open source packages ship an affected version, including github.com/gravitational/teleport.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/gravitational/teleport` | Go | All versions | None |
| `github.com/gravitational/teleport` | Go | All versions to 0.0.0-20250616162021-79b2f26125a1 | None |
| `github.com/gravitational/teleport` | Go | All versions to 0.0.0-20250616162021-79b2f26125a1 | None |
| `github.com/gravitational/teleport` | Go | From 0.0.11 | None |
| `github.com/gravitational/teleport` | Go | From 0.0.11 | 12.4.35 |
| `github.com/gravitational/teleport` | Go | From 0.0.11 | 12.4.35 |
| `github.com/gravitational/teleport` | Go | From 13.0.0 | 13.4.27 |
| `github.com/gravitational/teleport` | Go | From 13.0.0 | 13.4.27 |
| `github.com/gravitational/teleport` | Go | From 14.0.0 | 14.4.1 |
| `github.com/gravitational/teleport` | Go | From 14.0.0 | 14.4.1 |
| `github.com/gravitational/teleport` | Go | From 15.0.0 | 15.5.3 |
| `github.com/gravitational/teleport` | Go | From 15.0.0 | 15.5.3 |
| `github.com/gravitational/teleport` | Go | From 16.0.0 | 16.5.12 |
| `github.com/gravitational/teleport` | Go | From 16.0.0 | 16.5.12 |
| `github.com/gravitational/teleport` | Go | From 17.0.0 | 17.5.2 |
| `github.com/gravitational/teleport` | Go | From 17.0.0 | 17.5.2 |
| `teleport` | openSUSE:Tumbleweed | All versions | 17.5.3-1.1 |

## How do I fix CVE-2025-49825?

Upgrade github.com/gravitational/teleport to a fixed version for your release line: 12.4.35, 13.4.27, 14.4.1 or 15.5.3.

## Is CVE-2025-49825 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-49825 exists.

Public exploit code:

- Teleport - Authentication Bypass (nuclei): http/cves/2025/CVE-2025-49825.yaml

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-49825 and fix it if it is affected.

What it is: CVE-2025-49825 is a critical authentication bypass vulnerability in gravitational teleport, published on 17 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-49825 exists.

Affected packages and fixed versions:
- github.com/gravitational/teleport (Go): affected all versions; no fix listed
- github.com/gravitational/teleport (Go): affected all versions up to 0.0.0-20250616162021-79b2f26125a1; no fix listed
- github.com/gravitational/teleport (Go): affected all versions up to 0.0.0-20250616162021-79b2f26125a1; no fix listed
- github.com/gravitational/teleport (Go): affected from 0.0.11; no fix listed
- github.com/gravitational/teleport (Go): affected from 0.0.11; fixed in 12.4.35
- github.com/gravitational/teleport (Go): affected from 0.0.11; fixed in 12.4.35
- github.com/gravitational/teleport (Go): affected from 13.0.0; fixed in 13.4.27
- github.com/gravitational/teleport (Go): affected from 13.0.0; fixed in 13.4.27
- github.com/gravitational/teleport (Go): affected from 14.0.0; fixed in 14.4.1
- github.com/gravitational/teleport (Go): affected from 14.0.0; fixed in 14.4.1
- github.com/gravitational/teleport (Go): affected from 15.0.0; fixed in 15.5.3
- github.com/gravitational/teleport (Go): affected from 15.0.0; fixed in 15.5.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-49825/ (Markdown: https://insights.sbomify.com/CVE-2025-49825/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-49825
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-49825
- OSV: https://osv.dev/vulnerability/CVE-2025-49825

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-49825/
Summaries are generated and may contain mistakes; the official description above is the record.
