# CVE-2025-49826: Next.js DoS vulnerability via cache poisoning

> Attackers can poison the cache to serve empty responses, causing a Denial of Service for users accessing static pages in Next.js applications.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Jul 2025
- **Updated:** 8 Jul 2025
- **Also known as:** GHSA-67rr-84xm-4c7r

## What is CVE-2025-49826?

CVE-2025-49826 is a high-severity denial of service vulnerability in Vercel Next.js, published on 3 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Next.js is a React framework for building full-stack web applications. From versions 15.0.4-canary.51 to before 15.1.8, a cache poisoning bug leading to a Denial of Service (DoS) condition was found in Next.js. This issue does not impact customers hosted on Vercel. Under certain conditions, this issue may allow a HTTP 204 response to be cached for static pages, leading to the 204 response being served to all users attempting to access the page. This issue has been addressed in version 15.1.8.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2025-49826?

2 open source packages ship an affected version, including next. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `next` | npm | From 15.0.4-canary.51 | 15.1.8 |
| `next` | npm | From 15.0.4-canary.51 | 15.1.8 |

Products: Vercel Next.js.

## How do I fix CVE-2025-49826?

Upgrade next to 15.1.8 or later.

## Is CVE-2025-49826 being exploited?

There is no known exploitation of CVE-2025-49826 in the wild and no public exploit code.

## Other vulnerabilities in Vercel Next.js

- [CVE-2025-29927](https://insights.sbomify.com/CVE-2025-29927/): Authorization Bypass in Next.js Middleware (critical 9.1)
- [CVE-2026-44578](https://insights.sbomify.com/CVE-2026-44578/): Next.js: Server-side request forgery in applications using WebSocket upgrades (high 8.6)
- [CVE-2026-94483](https://insights.sbomify.com/CVE-2026-94483/): Next.js: Server-Side Request Forgery in Image Optimization (high 8.3)
- [CVE-2026-64642](https://insights.sbomify.com/CVE-2026-64642/): Next.js: Middleware / Proxy bypass in App Router applications using Turbopack and single locale (high 8.3)
- [CVE-2026-64645](https://insights.sbomify.com/CVE-2026-64645/): Next.js: Server-Side Request Forgery in rewrites via attacker-controlled destination hostname (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-49826 and fix it if it is affected.

What it is: CVE-2025-49826 is a high-severity denial of service vulnerability in Vercel Next.js, published on 3 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-49826 in the wild and no public exploit code.

Affected packages and fixed versions:
- next (npm): affected from 15.0.4-canary.51; fixed in 15.1.8
- next (npm): affected from 15.0.4-canary.51; fixed in 15.1.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-49826/ (Markdown: https://insights.sbomify.com/CVE-2025-49826/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-49826
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-49826
- OSV: https://osv.dev/vulnerability/CVE-2025-49826

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-49826/
Summaries are generated and may contain mistakes; the official description above is the record.
