CVE-2025-49845 Information disclosure in discourse

Medium 6.3 Published Updated

Users can view their own whisper posts after losing group permissions, exposing restricted content to unauthorized users.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-49845?

CVE-2025-49845 is a medium-severity vulnerability in Discourse Discourse, published on 25 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Discourse is an open-source discussion platform. The visibility of posts typed `whisper` is controlled via the `whispers_allowed_groups` site setting. Only users that belong to groups specified in the site setting are allowed to view posts typed `whisper`. However, it has been discovered that users of versions prior to 3.4.6 on the `stable` branch and prior to 3.5.0.beta8-dev on the `tests-passed` branch can continue to see their own whispers even after losing visibility of posts typed `whisper`. This issue is patched in versions 3.4.6 and 3.5.0.beta8-dev. No known workarounds are available.

Weakness: CWE-200

Which versions are affected by CVE-2025-49845?

1 open source package ship an affected version, including discourse. It affects 1 product.

PackageAffectedFixed in
discourse BitnamiAll versions3.4.6

Products include Discourse Discourse.

How do I fix CVE-2025-49845?

Upgrade discourse to 3.4.6 or later.

Is CVE-2025-49845 being exploited?

There is no known exploitation of CVE-2025-49845 in the wild and no public exploit code.

All Discourse Discourse vulnerabilities

Sources

Also known as BIT-discourse-2025-49845, GHSA-79qw-r73r-69gf.

Is CVE-2025-49845 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free