CVE-2025-50151 Apache Jena: Configuration files uploaded by administrative users are not check properly

High 8.8 Published Updated

Administrative users can upload configuration files with unvalidated paths, potentially allowing unauthorized file access or modification.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-50151?

CVE-2025-50151 is a high-severity path traversal vulnerability in Apache Jena, published on 21 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

File access paths in configuration files uploaded by users with administrator access are not validated.

This issue affects Apache Jena version up to 5.4.0.

Users are recommended to upgrade to version 5.5.0, which does not allow arbitrary configuration upload.

Weakness: CWE-20

Which versions are affected by CVE-2025-50151?

2 open source packages ship an affected version, including org.apache.jena:jena. It affects 1 product.

PackageAffectedFixed in
org.apache.jena:jena MavenAll versions5.5.0
org.apache.jena:jena MavenAll versions5.5.0

Products include Apache Jena.

How do I fix CVE-2025-50151?

Upgrade org.apache.jena:jena to 5.5.0 or later.

Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.

Is CVE-2025-50151 being exploited?

There is no known exploitation of CVE-2025-50151 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2025-50151, GHSA-xg9p-p463-3qjp, UBUNTU-CVE-2025-50151.

Is CVE-2025-50151 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free