# CVE-2025-50151: Apache Jena: Configuration files uploaded by administrative users are not check properly

> Administrative users can upload configuration files with unvalidated paths, potentially allowing unauthorized file access or modification.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Jul 2025
- **Updated:** 4 Nov 2025
- **Also known as:** DEBIAN-CVE-2025-50151, GHSA-xg9p-p463-3qjp, UBUNTU-CVE-2025-50151

## What is CVE-2025-50151?

CVE-2025-50151 is a high-severity path traversal vulnerability in Apache Jena, published on 21 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

File access paths in configuration files uploaded by users with administrator access are not validated.

This issue affects Apache Jena version up to 5.4.0.

Users are recommended to upgrade to version 5.5.0, which does not allow arbitrary configuration upload.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2025-50151?

2 open source packages ship an affected version, including org.apache.jena:jena. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.jena:jena` | Maven | All versions | 5.5.0 |
| `org.apache.jena:jena` | Maven | All versions | 5.5.0 |

Products: Apache Jena.

## How do I fix CVE-2025-50151?

Upgrade org.apache.jena:jena to 5.5.0 or later.

## Is CVE-2025-50151 being exploited?

There is no known exploitation of CVE-2025-50151 in the wild and no public exploit code.

## Other vulnerabilities in Apache Jena

- [CVE-2022-28890](https://insights.sbomify.com/CVE-2022-28890/): Processing external DTDs (critical 9.8)
- [CVE-2023-32200](https://insights.sbomify.com/CVE-2023-32200/): Apache Jena: Exposure of execution in script engine expressions. (high 8.8)
- [CVE-2025-49656](https://insights.sbomify.com/CVE-2025-49656/): Apache Jena: Administrative users can create files outside the server directory space via the admin UI (high 7.5)
- [CVE-2021-39239](https://insights.sbomify.com/CVE-2021-39239/): XML External Entity (XXE) vulnerability (high 7.5)
- [CVE-2023-22665](https://insights.sbomify.com/CVE-2023-22665/): Apache Jena: Exposure of arbitrary execution in script engine expressions. (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-50151 and fix it if it is affected.

What it is: CVE-2025-50151 is a high-severity path traversal vulnerability in Apache Jena, published on 21 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-50151 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.jena:jena (Maven): affected all versions; fixed in 5.5.0
- org.apache.jena:jena (Maven): affected all versions; fixed in 5.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-50151/ (Markdown: https://insights.sbomify.com/CVE-2025-50151/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-50151
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-50151
- OSV: https://osv.dev/vulnerability/CVE-2025-50151

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-50151/
Summaries are generated and may contain mistakes; the official description above is the record.
