{"answers":{"affected":"2 open source packages ship an affected version, including @openlist-frontend/openlist-frontend.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-50183 exists.","fix":"Upgrade @openlist-frontend/openlist-frontend to 4.0.0-rc.4 or later.","what":"CVE-2025-50183 is a medium-severity cross-site scripting vulnerability in OpenListTeam OpenList, published on 19 Jun 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-50183 and fix it if it is affected.\n\nWhat it is: CVE-2025-50183 is a medium-severity cross-site scripting vulnerability in OpenListTeam OpenList, published on 19 Jun 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-50183 exists.\n\nAffected packages and fixed versions:\n- @openlist-frontend/openlist-frontend (npm): affected all versions; fixed in 4.0.0-rc.4\n- @openlist-frontend/openlist-frontend (npm): affected all versions; fixed in 4.0.0-rc.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-50183/ (Markdown: https://insights.sbomify.com/CVE-2025-50183/index.md)","id":"CVE-2025-50183","markdown":"https://insights.sbomify.com/CVE-2025-50183/index.md","name":"CVE-2025-50183","record":{"aliases":["GHSA-2hw3-h8qx-hqqp"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenList frontend","requires_auth":"none","summary":"Stored XSS in OpenList frontend allows attackers to execute arbitrary JavaScript via malicious Python files viewed in the Markdown viewer.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"OpenList Frontend is a UI component for OpenList. Prior to version 4.0.0-rc.4, a vulnerability exists in the file preview/browsing feature of the application, where files with a .py extension that contain JavaScript code wrapped in \u003cscript\u003e tags may be interpreted and executed as HTML in certain modes. This leads to a stored XSS vulnerability. This issue has been patched in version 4.0.0-rc.4.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"OpenList (frontend) allows XSS Attacks in the built-in Markdown Viewer","id":"CVE-2025-50183","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":2,"n_references":2,"next":{"headline":"DbGate allows for File Traversal via file parameter","id":"CVE-2025-50184"},"packages":[{"ecosystem":"npm","fixed":["4.0.0-rc.4"],"introduced":["0"],"last_affected":[],"package":"@openlist-frontend/openlist-frontend","purl":null,"source":"GHSA-2hw3-h8qx-hqqp"},{"ecosystem":"npm","fixed":["4.0.0-rc.4"],"introduced":["0"],"last_affected":[],"package":"@openlist-frontend/openlist-frontend","purl":"pkg:npm/%40openlist-frontend/openlist-frontend","source":"GHSA-2hw3-h8qx-hqqp"}],"prev":{"headline":"urllib3 does not control redirects in browsers and Node.js","id":"CVE-2025-50182"},"products":["OpenList"],"published":"2025-06-19","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-06-23","vendors":["OpenListTeam"]},"summary":"Stored XSS in OpenList frontend allows attackers to execute arbitrary JavaScript via malicious Python files viewed in the Markdown viewer.","url":"https://insights.sbomify.com/CVE-2025-50183/"}