# CVE-2025-50202: Lychee Path Traversal Vulnerability

> An attacker can exploit a path traversal flaw in Lychee to leak local files, including environment variables and configuration secrets.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 18 Jun 2025
- **Updated:** 18 Jun 2025
- **Also known as:** GHSA-6rj9-gm78-vhf9

## What is CVE-2025-50202?

CVE-2025-50202 is a high-severity path traversal vulnerability in LycheeOrg Lychee, published on 18 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Lychee is a free photo-management tool. In versions starting from 6.6.6 to before 6.6.10, an attacker can leak local files including environment variables, nginx logs, other user's uploaded images, and configuration secrets due to a path traversal exploit in SecurePathController.php. This issue has been patched in version 6.6.10.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2025-50202?


## How do I fix CVE-2025-50202?

No fix has been published for CVE-2025-50202 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-50202 being exploited?

There is no known exploitation of CVE-2025-50202 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-50202 and fix it if it is affected.

What it is: CVE-2025-50202 is a high-severity path traversal vulnerability in LycheeOrg Lychee, published on 18 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-50202 in the wild and no public exploit code.

Affected product: LycheeOrg Lychee. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-50202/ (Markdown: https://insights.sbomify.com/CVE-2025-50202/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-50202
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-50202
- OSV: https://osv.dev/vulnerability/CVE-2025-50202

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-50202/
Summaries are generated and may contain mistakes; the official description above is the record.
