{"answers":{"affected":"3 open source packages ship an affected version, including apache-airflow-providers-snowflake. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-50213 in the wild and no public exploit code.","fix":"Upgrade apache-airflow-providers-snowflake to 6.4.0 or later.","what":"CVE-2025-50213 is a critical SQL injection vulnerability in Apache Airflow Providers Snowflake, published on 24 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-50213 and fix it if it is affected.\n\nWhat it is: CVE-2025-50213 is a critical SQL injection vulnerability in Apache Airflow Providers Snowflake, published on 24 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-50213 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apache-airflow-providers-snowflake (PyPI): affected all versions; fixed in 6.4.0\n- apache-airflow-providers-snowflake (PyPI): affected all versions; fixed in 6.4.0\n- apache-airflow-providers-snowflake (PyPI): affected all versions; fixed in 6.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-50213/ (Markdown: https://insights.sbomify.com/CVE-2025-50213/index.md)","id":"CVE-2025-50213","markdown":"https://insights.sbomify.com/CVE-2025-50213/index.md","name":"CVE-2025-50213","record":{"aliases":["ECHO-b963-92f2-cbc3","GHSA-9r64-3wmc-x8m8","PYSEC-2025-51","ROOT-APP-PYPI-CVE-2025-50213"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Airflow Snowflake provider","requires_auth":"none","summary":"Attackers can execute arbitrary SQL commands via unsanitized parameters in the Snowflake operator, requiring an upgrade to the provider library.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"apache-airflow-providers-snowflake","vendor":"apache"}],"cvss":{"score":9.8,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-75","name":"Failure to Sanitize Special Elements into a Different Plane"}],"description":"Failure to Sanitize Special Elements into a Different Plane (Special Element Injection) vulnerability in Apache Airflow Providers Snowflake.\n\nThis issue affects Apache Airflow Providers Snowflake: before 6.4.0.\n\nSanitation of table and stage parameters were added in CopyFromExternalStageToSnowflakeOperator to prevent SQL injection\nUsers are recommended to upgrade to version 6.4.0, which fixes the issue.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Airflow Providers Snowflake: Potential SQL injection in CopyFromExternalStageToSnowflakeOperator","id":"CVE-2025-50213","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"sql_injection","year":"2025"},"n_packages":3,"n_references":2,"next":{"headline":"Server-side request forgery in n/a","id":"CVE-2025-50228"},"packages":[{"ecosystem":"PyPI","fixed":["6.4.0"],"introduced":["0"],"last_affected":[],"package":"apache-airflow-providers-snowflake","purl":null,"source":"GHSA-9r64-3wmc-x8m8"},{"ecosystem":"PyPI","fixed":["6.4.0"],"introduced":["0"],"last_affected":[],"package":"apache-airflow-providers-snowflake","purl":"pkg:pypi/apache-airflow-providers-snowflake","source":"GHSA-9r64-3wmc-x8m8"},{"ecosystem":"PyPI","fixed":["6.4.0"],"introduced":["0"],"last_affected":[],"package":"apache-airflow-providers-snowflake","purl":"pkg:pypi/apache-airflow-providers-snowflake","source":"PYSEC-2025-51"}],"prev":{"headline":"Lychee Path Traversal Vulnerability","id":"CVE-2025-50202"},"products":["Apache Airflow Providers Snowflake"],"published":"2025-06-24","related":[{"cvss_score":6.3,"headline":"Apache Airflow Snowflake provider: Unvalidated account field redirects SQL API bearer token off-domain","id":"CVE-2026-81930","kev_date_added":null,"published":"2026-09-29"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-06-24","vendors":["Apache Software Foundation"]},"summary":"Attackers can execute arbitrary SQL commands via unsanitized parameters in the Snowflake operator, requiring an upgrade to the provider library.","url":"https://insights.sbomify.com/CVE-2025-50213/"}