# CVE-2025-50213: Apache Airflow Providers Snowflake: Potential SQL injection in CopyFromExternalStageToSnowflakeOperator

> Attackers can execute arbitrary SQL commands via unsanitized parameters in the Snowflake operator, requiring an upgrade to the provider library.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Jun 2025
- **Updated:** 24 Jun 2025
- **Also known as:** ECHO-b963-92f2-cbc3, GHSA-9r64-3wmc-x8m8, PYSEC-2025-51, ROOT-APP-PYPI-CVE-2025-50213

## What is CVE-2025-50213?

CVE-2025-50213 is a critical SQL injection vulnerability in Apache Airflow Providers Snowflake, published on 24 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Failure to Sanitize Special Elements into a Different Plane (Special Element Injection) vulnerability in Apache Airflow Providers Snowflake.

This issue affects Apache Airflow Providers Snowflake: before 6.4.0.

Sanitation of table and stage parameters were added in CopyFromExternalStageToSnowflakeOperator to prevent SQL injection
Users are recommended to upgrade to version 6.4.0, which fixes the issue.

Weakness: CWE-75 (Failure to Sanitize Special Elements into a Different Plane)

## Which versions are affected by CVE-2025-50213?

3 open source packages ship an affected version, including apache-airflow-providers-snowflake. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow-providers-snowflake` | PyPI | All versions | 6.4.0 |
| `apache-airflow-providers-snowflake` | PyPI | All versions | 6.4.0 |
| `apache-airflow-providers-snowflake` | PyPI | All versions | 6.4.0 |

Products: Apache Apache-Airflow-Providers-Snowflake.

## How do I fix CVE-2025-50213?

Upgrade apache-airflow-providers-snowflake to 6.4.0 or later.

## Is CVE-2025-50213 being exploited?

There is no known exploitation of CVE-2025-50213 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow Providers Snowflake

- [CVE-2026-81930](https://insights.sbomify.com/CVE-2026-81930/): Apache Airflow Snowflake provider: Unvalidated account field redirects SQL API bearer token off-domain (medium 6.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-50213 and fix it if it is affected.

What it is: CVE-2025-50213 is a critical SQL injection vulnerability in Apache Airflow Providers Snowflake, published on 24 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-50213 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow-providers-snowflake (PyPI): affected all versions; fixed in 6.4.0
- apache-airflow-providers-snowflake (PyPI): affected all versions; fixed in 6.4.0
- apache-airflow-providers-snowflake (PyPI): affected all versions; fixed in 6.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-50213/ (Markdown: https://insights.sbomify.com/CVE-2025-50213/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-50213
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-50213
- OSV: https://osv.dev/vulnerability/CVE-2025-50213

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-50213/
Summaries are generated and may contain mistakes; the official description above is the record.
