CVE-2025-50383 Easy!Appointments SQL injection vulnerability
Attackers can execute arbitrary SQL commands via the order_by parameter in Easy!Appointments, potentially reading or modifying database contents.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-50383?
CVE-2025-50383 is a high-severity SQL injection vulnerability in n/a, published on 25 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
alextselegidis Easy!Appointments v1.5.1 was discovered to contain a SQL injection vulnerability via the order_by parameter.
Weakness: CWE-89
Which versions are affected by CVE-2025-50383?
2 open source packages ship an affected version, including alextselegidis/easyappointments. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
alextselegidis/easyappointments Packagist | All versions | 1.5.2-beta.1 |
alextselegidis/easyappointments Packagist | All versions | 1.5.2-beta.1 |
Products include Easyappointments Easy\!appointments.
How do I fix CVE-2025-50383?
Upgrade alextselegidis/easyappointments to 1.5.2-beta.1 or later.
Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.
Is CVE-2025-50383 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-50383 exists.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in n/a
- CVE-2025-29448 Easy!Appointments Denial of Service (DoS)
- CVE-2018-13063 Missing authorization in n/a
- CVE-2026-23622 CSRF Protection Bypass: Sensitive endpoints accept GET requests, enabling admin account takeover
- CVE-2018-13060 Security feature bypass in n/a
- CVE-2024-0698 Easy!Appointments <= 1.3.1 - Authenticated (Contributor+) Stored Cross-Site Scripting
Sources
Also known as GHSA-2f28-69j7-85hf.