# CVE-2025-50383: Easy!Appointments SQL injection vulnerability

> Attackers can execute arbitrary SQL commands via the order_by parameter in Easy!Appointments, potentially reading or modifying database contents.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Aug 2025
- **Updated:** 5 Jul 2026
- **Also known as:** GHSA-2f28-69j7-85hf

## What is CVE-2025-50383?

CVE-2025-50383 is a high-severity SQL injection vulnerability in n/a, published on 25 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

alextselegidis Easy!Appointments v1.5.1 was discovered to contain a SQL injection vulnerability via the order_by parameter.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2025-50383?

2 open source packages ship an affected version, including alextselegidis/easyappointments. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `alextselegidis/easyappointments` | Packagist | All versions | 1.5.2-beta.1 |
| `alextselegidis/easyappointments` | Packagist | All versions | 1.5.2-beta.1 |

Products: Easyappointments Easy\!appointments.

## How do I fix CVE-2025-50383?

Upgrade alextselegidis/easyappointments to 1.5.2-beta.1 or later.

## Is CVE-2025-50383 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-50383 exists.

Public exploit code:

- A low-privileged user can exploit this via a crafted order_by parameter, causing time-based blind SQL injection. (github_poc): https://github.com/Abdullah4eb/CVE-2025-50383

## Other vulnerabilities in n/a

- [CVE-2025-29448](https://insights.sbomify.com/CVE-2025-29448/): Easy!Appointments Denial of Service (DoS) (high 7.5)
- [CVE-2018-13063](https://insights.sbomify.com/CVE-2018-13063/): Missing authorization in n/a (high 7.5)
- [CVE-2026-23622](https://insights.sbomify.com/CVE-2026-23622/): CSRF Protection Bypass: Sensitive endpoints accept GET requests, enabling admin account takeover (high 7.4)
- [CVE-2018-13060](https://insights.sbomify.com/CVE-2018-13060/): Security feature bypass in n/a (medium 6.5)
- [CVE-2024-0698](https://insights.sbomify.com/CVE-2024-0698/): Easy!Appointments <= 1.3.1 - Authenticated (Contributor+) Stored Cross-Site Scripting (medium 6.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-50383 and fix it if it is affected.

What it is: CVE-2025-50383 is a high-severity SQL injection vulnerability in n/a, published on 25 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-50383 exists.

Affected packages and fixed versions:
- alextselegidis/easyappointments (Packagist): affected all versions; fixed in 1.5.2-beta.1
- alextselegidis/easyappointments (Packagist): affected all versions; fixed in 1.5.2-beta.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-50383/ (Markdown: https://insights.sbomify.com/CVE-2025-50383/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-50383
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-50383
- OSV: https://osv.dev/vulnerability/CVE-2025-50383

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-50383/
Summaries are generated and may contain mistakes; the official description above is the record.
