{"answers":{"affected":"3 open source packages ship an affected version, including ms-swift.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-50460 exists.","fix":"No fix has been published for CVE-2025-50460 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-50460 is a critical unsafe deserialization vulnerability in n/a, published on 1 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-50460 and fix it if it is affected.\n\nWhat it is: CVE-2025-50460 is a critical unsafe deserialization vulnerability in n/a, published on 1 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-50460 exists.\n\nAffected packages and fixed versions:\n- ms-swift (PyPI): affected all versions up to 3.6.3; no fix listed\n- ms-swift (PyPI): affected all versions up to 3.6.3; no fix listed\n- ms-swift (PyPI): affected all versions up to 3.6.3; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-50460/ (Markdown: https://insights.sbomify.com/CVE-2025-50460/index.md)","id":"CVE-2025-50460","markdown":"https://insights.sbomify.com/CVE-2025-50460/index.md","name":"CVE-2025-50460","record":{"aliases":["GHSA-fm6c-f59h-7mmg","PYSEC-2026-1683"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python machine learning library","requires_auth":"none","summary":"Attackers can execute arbitrary code via unsafe YAML deserialization in ms-swift if they control the configuration file, requiring an upgrade to PyYAML.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":9.8,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"A remote code execution (RCE) vulnerability exists in the ms-swift project version 3.3.0 due to unsafe deserialization in tests/run.py using yaml.load() from the PyYAML library (versions = 5.3.1). If an attacker can control the content of the YAML configuration file passed to the --run_config parameter, arbitrary code can be executed during deserialization. This can lead to full system compromise. The vulnerability is triggered when a malicious YAML file is loaded, allowing the execution of arbitrary Python commands such as os.system(). It is recommended to upgrade PyYAML to version 5.4 or higher, and to use yaml.safe_load() to mitigate the issue.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":"2025-07-30","github_poc":2,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2025-07-30T06:37:46Z","kind":"github_poc","ref":"https://github.com/Anchor0221/CVE-2025-50460","stars":0,"title":"Technical Details and Exploit for CVE-2025-50460"},{"date":"2026-10-07T15:40:34Z","kind":"github_poc","ref":"https://github.com/ferralon-demo/ms-swift-yaml-load-rce","stars":0,"title":"Case study: ms-swift CVE-2025-50460 (unsafe yaml.load in tests/run.py). Demo only, not for use."}],"tier":"weaponised"},"has_fix":false,"headline":"MS SWIFT Remote Code Execution via unsafe PyYAML deserialization","id":"CVE-2025-50460","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"deserialization","year":"2025"},"n_packages":3,"n_references":4,"next":{"headline":"Deserialization in n/a","id":"CVE-2025-50461"},"packages":[{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":["3.6.3"],"package":"ms-swift","purl":null,"source":"GHSA-fm6c-f59h-7mmg"},{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":["3.6.3"],"package":"ms-swift","purl":"pkg:pypi/ms-swift","source":"GHSA-fm6c-f59h-7mmg"},{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":["3.6.3"],"package":"ms-swift","purl":"pkg:pypi/ms-swift","source":"PYSEC-2026-1683"}],"prev":{"headline":"SQL injection in n/a","id":"CVE-2025-50455"},"products":["n/a"],"published":"2025-08-01","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-08-01","vendors":["n/a"]},"summary":"Attackers can execute arbitrary code via unsafe YAML deserialization in ms-swift if they control the configuration file, requiring an upgrade to PyYAML.","url":"https://insights.sbomify.com/CVE-2025-50460/"}