# CVE-2025-50460: MS SWIFT Remote Code Execution via unsafe PyYAML deserialization

> Attackers can execute arbitrary code via unsafe YAML deserialization in ms-swift if they control the configuration file, requiring an upgrade to PyYAML.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 1 Aug 2025
- **Updated:** 1 Aug 2025
- **Also known as:** GHSA-fm6c-f59h-7mmg, PYSEC-2026-1683

## What is CVE-2025-50460?

CVE-2025-50460 is a critical unsafe deserialization vulnerability in n/a, published on 1 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A remote code execution (RCE) vulnerability exists in the ms-swift project version 3.3.0 due to unsafe deserialization in tests/run.py using yaml.load() from the PyYAML library (versions = 5.3.1). If an attacker can control the content of the YAML configuration file passed to the --run_config parameter, arbitrary code can be executed during deserialization. This can lead to full system compromise. The vulnerability is triggered when a malicious YAML file is loaded, allowing the execution of arbitrary Python commands such as os.system(). It is recommended to upgrade PyYAML to version 5.4 or higher, and to use yaml.safe_load() to mitigate the issue.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2025-50460?

3 open source packages ship an affected version, including ms-swift.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ms-swift` | PyPI | All versions to 3.6.3 | None |
| `ms-swift` | PyPI | All versions to 3.6.3 | None |
| `ms-swift` | PyPI | All versions to 3.6.3 | None |

## How do I fix CVE-2025-50460?

No fix has been published for CVE-2025-50460 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-50460 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-50460 exists.

Public exploit code:

- Technical Details and Exploit for CVE-2025-50460 (github_poc): https://github.com/Anchor0221/CVE-2025-50460
- Case study: ms-swift CVE-2025-50460 (unsafe yaml.load in tests/run.py). Demo only, not for use. (github_poc): https://github.com/ferralon-demo/ms-swift-yaml-load-rce

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-50460 and fix it if it is affected.

What it is: CVE-2025-50460 is a critical unsafe deserialization vulnerability in n/a, published on 1 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-50460 exists.

Affected packages and fixed versions:
- ms-swift (PyPI): affected all versions up to 3.6.3; no fix listed
- ms-swift (PyPI): affected all versions up to 3.6.3; no fix listed
- ms-swift (PyPI): affected all versions up to 3.6.3; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-50460/ (Markdown: https://insights.sbomify.com/CVE-2025-50460/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-50460
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-50460
- OSV: https://osv.dev/vulnerability/CVE-2025-50460

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-50460/
Summaries are generated and may contain mistakes; the official description above is the record.
