# CVE-2025-50738: Memos has Cross-Site Scripting (XSS) Vulnerability in Image URLs

> Attackers can track users and disclose IP addresses by embedding malicious image URLs in Memos notes, requiring an upgrade to mitigate.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Jul 2025
- **Updated:** 22 Aug 2025
- **Also known as:** GHSA-hfcf-79gh-f3jc, GO-2025-3831

## What is CVE-2025-50738?

CVE-2025-50738 is a critical vulnerability in Usememos Memos, published on 29 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Memos application, up to version v0.24.3, allows for the embedding of markdown images with arbitrary URLs. When a user views a memo containing such an image, their browser automatically fetches the image URL without explicit user consent or interaction beyond viewing the memo. This can be exploited by an attacker to disclose the viewing user's IP address, browser User-Agent string, and potentially other request-specific information to the attacker-controlled server, leading to information disclosure and user tracking.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2025-50738?

3 open source packages ship an affected version, including github.com/usememos/memos. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/usememos/memos` | Go | All versions | 0.24.4 |
| `github.com/usememos/memos` | Go | All versions | 0.24.4 |
| `github.com/usememos/memos` | Go | All versions | 0.24.4 |

Products: Usememos Memos.

## How do I fix CVE-2025-50738?

Upgrade github.com/usememos/memos to 0.24.4 or later.

## Is CVE-2025-50738 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-50738 exists.

Public exploit code:

- Stored Cross-Site Scripting in "usememos" via SVG (github_poc): https://github.com/tiemio/CVE-2025-50738-PoC

## Other vulnerabilities in Usememos Memos

- [CVE-2025-22952](https://insights.sbomify.com/CVE-2025-22952/): Memos Server-Side Request Forgery (SSRF) (critical 9.8)
- [CVE-2023-0109](https://insights.sbomify.com/CVE-2023-0109/): Stored XSS in usememos/memos (critical 9.8)
- [CVE-2023-4696](https://insights.sbomify.com/CVE-2023-4696/): Improper Access Control in usememos/memos (critical 9.8)
- [CVE-2022-4866](https://insights.sbomify.com/CVE-2022-4866/): Cross-site Scripting (XSS) - Stored in usememos/memos (critical 9.8)
- [CVE-2022-4851](https://insights.sbomify.com/CVE-2022-4851/): Improper Handling of Values in usememos/memos (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-50738 and fix it if it is affected.

What it is: CVE-2025-50738 is a critical vulnerability in Usememos Memos, published on 29 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-50738 exists.

Affected packages and fixed versions:
- github.com/usememos/memos (Go): affected all versions; fixed in 0.24.4
- github.com/usememos/memos (Go): affected all versions; fixed in 0.24.4
- github.com/usememos/memos (Go): affected all versions; fixed in 0.24.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-50738/ (Markdown: https://insights.sbomify.com/CVE-2025-50738/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-50738
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-50738
- OSV: https://osv.dev/vulnerability/CVE-2025-50738

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-50738/
Summaries are generated and may contain mistakes; the official description above is the record.
