{"answers":{"affected":"2 open source packages ship an affected version, including @elysiajs/cors.","exploited":"There is no known exploitation of CVE-2025-50864 in the wild and no public exploit code.","fix":"Upgrade @elysiajs/cors to 1.3.1 or later.","what":"CVE-2025-50864 is a medium-severity vulnerability in n/a, published on 20 Aug 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-50864 and fix it if it is affected.\n\nWhat it is: CVE-2025-50864 is a medium-severity vulnerability in n/a, published on 20 Aug 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-50864 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @elysiajs/cors (npm): affected all versions; fixed in 1.3.1\n- @elysiajs/cors (npm): affected all versions; fixed in 1.3.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-50864/ (Markdown: https://insights.sbomify.com/CVE-2025-50864/index.md)","id":"CVE-2025-50864","markdown":"https://insights.sbomify.com/CVE-2025-50864/index.md","name":"CVE-2025-50864","record":{"aliases":["GHSA-f9qj-4c5x-cpcw"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Elysia CORS library","requires_auth":"none","summary":"Attackers can bypass CORS restrictions in the elysia-cors library by using substring-matched origins, enabling unauthorized access to user data.","user_interaction":"required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":6.5,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-178","name":"Improper Handling of Case Sensitivity"}],"description":"An Origin Validation Error in the elysia-cors library thru 1.3.0 allows attackers to bypass Cross-Origin Resource Sharing (CORS) restrictions. The library incorrectly validates the supplied origin by checking if it is a substring of any domain in the site's CORS policy, rather than performing an exact match. For example, a malicious origin like \"notexample.com\", \"example.common.net\" is whitelisted when the site's CORS policy specifies \"example.com.\" This vulnerability enables unauthorized access to user data on sites using the elysia-cors library for CORS validation.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"elysia-cors Origin Validation Error","id":"CVE-2025-50864","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"security_feature_bypass","year":"2025"},"n_packages":2,"n_references":4,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2025-50866"},"packages":[{"ecosystem":"npm","fixed":["1.3.1"],"introduced":["0"],"last_affected":[],"package":"@elysiajs/cors","purl":null,"source":"GHSA-f9qj-4c5x-cpcw"},{"ecosystem":"npm","fixed":["1.3.1"],"introduced":["0"],"last_affected":[],"package":"@elysiajs/cors","purl":"pkg:npm/%40elysiajs/cors","source":"GHSA-f9qj-4c5x-cpcw"}],"prev":{"headline":"Information disclosure in n/a","id":"CVE-2025-50862"},"products":["n/a"],"published":"2025-08-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-05","vendors":["n/a"]},"summary":"Attackers can bypass CORS restrictions in the elysia-cors library by using substring-matched origins, enabling unauthorized access to user data.","url":"https://insights.sbomify.com/CVE-2025-50864/"}