# CVE-2025-50864: elysia-cors Origin Validation Error

> Attackers can bypass CORS restrictions in the elysia-cors library by using substring-matched origins, enabling unauthorized access to user data.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Aug 2025
- **Updated:** 5 Jul 2026
- **Also known as:** GHSA-f9qj-4c5x-cpcw

## What is CVE-2025-50864?

CVE-2025-50864 is a medium-severity vulnerability in n/a, published on 20 Aug 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

An Origin Validation Error in the elysia-cors library thru 1.3.0 allows attackers to bypass Cross-Origin Resource Sharing (CORS) restrictions. The library incorrectly validates the supplied origin by checking if it is a substring of any domain in the site's CORS policy, rather than performing an exact match. For example, a malicious origin like "notexample.com", "example.common.net" is whitelisted when the site's CORS policy specifies "example.com." This vulnerability enables unauthorized access to user data on sites using the elysia-cors library for CORS validation.

Weakness: CWE-178 (Improper Handling of Case Sensitivity)

## Which versions are affected by CVE-2025-50864?

2 open source packages ship an affected version, including @elysiajs/cors.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@elysiajs/cors` | npm | All versions | 1.3.1 |
| `@elysiajs/cors` | npm | All versions | 1.3.1 |

## How do I fix CVE-2025-50864?

Upgrade @elysiajs/cors to 1.3.1 or later.

## Is CVE-2025-50864 being exploited?

There is no known exploitation of CVE-2025-50864 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-50864 and fix it if it is affected.

What it is: CVE-2025-50864 is a medium-severity vulnerability in n/a, published on 20 Aug 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-50864 in the wild and no public exploit code.

Affected packages and fixed versions:
- @elysiajs/cors (npm): affected all versions; fixed in 1.3.1
- @elysiajs/cors (npm): affected all versions; fixed in 1.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-50864/ (Markdown: https://insights.sbomify.com/CVE-2025-50864/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-50864
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-50864
- OSV: https://osv.dev/vulnerability/CVE-2025-50864

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-50864/
Summaries are generated and may contain mistakes; the official description above is the record.
