CVE-2025-5115 MadeYouReset HTTP/2 vulnerability
A remote attacker can cause resource exhaustion and denial of service in Eclipse Jetty by sending malformed HTTP/2 frames that trigger excessive RST_STREAM processing.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-5115?
CVE-2025-5115 is a high-severity denial of service vulnerability in Eclipse Jetty, published on 20 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In Eclipse Jetty, versions <=9.4.57, <=10.0.25, <=11.0.25, <=12.0.21, <=12.1.0.alpha2, an HTTP/2 client may trigger the server to send RST_STREAM frames, for example by sending frames that are malformed or that should not be sent in a particular stream state, therefore forcing the server to consume resources such as CPU and memory.
For example, a client can open a stream and then send WINDOW_UPDATE frames with window size increment of 0, which is illegal. Per specification https://www.rfc-editor.org/rfc/rfc9113.html#name-window_update , the server should send a RST_STREAM frame. The client can now open another stream and send another bad WINDOW_UPDATE, therefore causing the server to consume more resources than necessary, as this case does not exceed the max number of concurrent streams, yet the client is able to create an enormous amount of streams in a short period of time.
The attack can be performed with other conditions (for example, a DATA frame for a closed stream) that cause the server to send a RST_STREAM frame.
Links:
* https://github.com/jetty/jetty.project/security/advisories/GHSA-mmxm-8w33-wc4h
Weakness: CWE-400
Which versions are affected by CVE-2025-5115?
10 open source packages ship an affected version, including org.eclipse.jetty.http2:http2-common and org.eclipse.jetty.http2:jetty-http2-common. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.eclipse.jetty.http2:http2-common Maven | From 10.0.0 | 10.0.26 |
org.eclipse.jetty.http2:http2-common Maven | From 10.0.0 | 10.0.26 |
org.eclipse.jetty.http2:http2-common Maven | From 11.0.0 | 11.0.26 |
org.eclipse.jetty.http2:http2-common Maven | From 11.0.0 | 11.0.26 |
org.eclipse.jetty.http2:http2-common Maven | From 9.3.0 | 9.4.58 |
org.eclipse.jetty.http2:http2-common Maven | From 9.3.0 | 9.4.58 |
4 more packages
org.eclipse.jetty.http2:jetty-http2-common Maven | From 12.0.0 | 12.0.25 |
org.eclipse.jetty.http2:jetty-http2-common Maven | From 12.0.0 | 12.0.25 |
org.eclipse.jetty.http2:jetty-http2-common Maven | From 12.1.0.alpha0 | 12.1.0.beta3 |
org.eclipse.jetty.http2:jetty-http2-common Maven | From 12.1.0.alpha0 | 12.1.0.beta3 |
Linux distribution packages (30)
jenkins Red Hat:ocp_tools:4.12::el8 | All versions | 0:2.516.3.1758299374-3.el8 |
jenkins-2-plugins Red Hat:ocp_tools:4.12::el8 | All versions | 0:4.12.1758299735-1.el8 |
jenkins Red Hat:ocp_tools:4.13::el8 | All versions | 0:2.516.3.1758298953-3.el8 |
jenkins-2-plugins Red Hat:ocp_tools:4.13::el8 | All versions | 0:4.13.1758299004-1.el8 |
jenkins Red Hat:ocp_tools:4.14::el8 | All versions | 0:2.516.3.1758302106-3.el8 |
jenkins-2-plugins Red Hat:ocp_tools:4.14::el8 | All versions | 0:4.14.1758302383-1.el8 |
jenkins Red Hat:ocp_tools:4.15::el8 | All versions | 0:2.516.3.1758302665-3.el8 |
jenkins-2-plugins Red Hat:ocp_tools:4.15::el8 | All versions | 0:4.15.1758303157-1.el8 |
jenkins Red Hat:ocp_tools:4.16::el9 | All versions | 0:2.516.3.1758336945-3.el9 |
jenkins-2-plugins Red Hat:ocp_tools:4.16::el9 | All versions | 0:4.16.1758337173-1.el9 |
jenkins Red Hat:ocp_tools:4.17::el9 | All versions | 0:2.516.3.1758259817-3.el9 |
jenkins-2-plugins Red Hat:ocp_tools:4.17::el9 | All versions | 0:4.17.1758260106-1.el9 |
jenkins Red Hat:ocp_tools:4.18::el9 | All versions | 0:2.516.3.1758260563-3.el9 |
jenkins-2-plugins Red Hat:ocp_tools:4.18::el9 | All versions | 0:4.18.1758260849-1.el9 |
jenkins Red Hat:ocp_tools:4.19::el9 | All versions | 0:2.516.3.1758206866-3.el9 |
jenkins-2-plugins Red Hat:ocp_tools:4.19::el9 | All versions | 0:4.19.1758207171-1.el9 |
jetty-minimal SUSE:Enterprise Storage 7.1 | All versions | 9.4.58-150200.3.34.1 |
jetty-minimal SUSE:Linux Enterprise High Performance Computing 15 SP3-LTSS | All versions | 9.4.58-150200.3.34.1 |
jetty-minimal SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS | All versions | 9.4.58-150200.3.34.1 |
jetty-minimal SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS | All versions | 9.4.58-150200.3.34.1 |
jetty-minimal SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS | All versions | 9.4.58-150200.3.34.1 |
jetty-minimal SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS | All versions | 9.4.58-150200.3.34.1 |
jetty-minimal SUSE:Linux Enterprise Module for Development Tools 15 SP6 | All versions | 9.4.58-150200.3.34.1 |
jetty-minimal SUSE:Linux Enterprise Module for Development Tools 15 SP7 | All versions | 9.4.58-150200.3.34.1 |
jetty-minimal SUSE:Linux Enterprise Module for Package Hub 15 SP6 | All versions | 9.4.58-150200.3.34.1 |
jetty-minimal SUSE:Linux Enterprise Module for Package Hub 15 SP7 | All versions | 9.4.58-150200.3.34.1 |
jetty-minimal SUSE:Linux Enterprise Server 15 SP3-LTSS | All versions | 9.4.58-150200.3.34.1 |
jetty-minimal SUSE:Linux Enterprise Server 15 SP4-LTSS | All versions | 9.4.58-150200.3.34.1 |
jetty-minimal SUSE:Linux Enterprise Server 15 SP5-LTSS | All versions | 9.4.58-150200.3.34.1 |
jetty-minimal SUSE:Linux Enterprise Server for SAP Applications 15 SP3 | All versions | 9.4.58-150200.3.34.1 |
Products include Eclipse Jetty.
How do I fix CVE-2025-5115?
Upgrade org.eclipse.jetty.http2:http2-common to a fixed version for your release line: 10.0.26, 11.0.26 or 9.4.58.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2025-5115 being exploited?
There is no known exploitation of CVE-2025-5115 in the wild and no public exploit code.
Other vulnerabilities in Eclipse Jetty
- CVE-2016-4800 Jetty contains an alias issue that could allow unauthenticated remote code execution due to specially crafted request
- CVE-2019-17638 Operation on a Resource after Expiration or Release in Jetty Server
- CVE-2018-12538 Access and integrity issue within Eclipse Jetty
- CVE-2026-10050 Digest authentication lossy encoding
- CVE-2024-7708 Eclipse Jetty: DoS attack triggering OutOfMemory with 100-Continue requests
Sources
Also known as CLEANSTART-2026-DA06561, CLEANSTART-2026-QB24702, CLEANSTART-2026-TW91822, CLSA-2026-1786553094, DEBIAN-CVE-2025-5115, DLA-4299-1 and 25 more.