CVE-2025-5126 Teledyne FLIR AX8 settingsregional.php setDataTime command injection

High 8.7 Published Updated

Remote attackers can execute arbitrary commands via manipulated time parameters in the settingsregional.php file of Teledyne FLIR AX8 devices.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-5126?

CVE-2025-5126 is a high-severity command injection vulnerability in Teledyne FLIR AX8, published on 24 May 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A vulnerability was found in Teledyne FLIR AX8 up to 1.46.16. This vulnerability affects the function setDataTime of the file \usr\www\application\models\settingsregional.php. Performing manipulation of the argument year/month/day/hour/minute results in command injection. The attack may be initiated remotely. The exploit has been made public and could be used. Upgrading to version 1.49.16 is able to resolve this issue. Upgrading the affected component is recommended. The vendor points out: "FLIR AX8 internal web site has been refactored to be able to handle the reported vulnerabilities."

Weakness: CWE-77, CWE-74

Which versions are affected by CVE-2025-5126?

It affects 1 product.

Products include Flir Flir Ax8 Firmware.

How do I fix CVE-2025-5126?

No fix has been published for CVE-2025-5126 yet. Limit exposure of the affected software until one is available.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2025-5126 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-5126 exists.

Sources

Also known as GHSA-ph28-r5c9-qfxx.

Is CVE-2025-5126 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free