{"answers":{"affected":"3 open source packages ship an affected version, including modelscope.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-51427 exists.","fix":"Upgrade modelscope to 1.27.0 or later.","what":"CVE-2025-51427 is a high-severity unsafe deserialization vulnerability in n/a, published on 19 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-51427 and fix it if it is affected.\n\nWhat it is: CVE-2025-51427 is a high-severity unsafe deserialization vulnerability in n/a, published on 19 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-51427 exists.\n\nAffected packages and fixed versions:\n- modelscope (PyPI): affected all versions; fixed in 1.27.0\n- modelscope (PyPI): affected all versions; fixed in 1.27.0\n- modelscope (PyPI): affected all versions; fixed in 1.27.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-51427/ (Markdown: https://insights.sbomify.com/CVE-2025-51427/index.md)","id":"CVE-2025-51427","markdown":"https://insights.sbomify.com/CVE-2025-51427/index.md","name":"CVE-2025-51427","record":{"aliases":["GHSA-fhhq-h4hg-549x","PYSEC-2026-2663"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"ModelScope Python library","requires_auth":"none","summary":"Attackers can execute arbitrary code by crafting a malicious module entry in the configuration file, affecting ModelScope users.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":7.3,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"},{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"An issue was discovered in ModelScope 1.25.0 allowing attackers to execute arbitrary code via crafted module listed in the configuration file (dey_mini.yaml) under the key ['nnet']['module'].","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"ModelScope is vulnerable to arbitrary code injection via a crafted module","id":"CVE-2025-51427","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"deserialization","year":"2025"},"n_packages":3,"n_references":3,"next":{"headline":"Auth bypass in n/a","id":"CVE-2025-51451"},"packages":[{"ecosystem":"PyPI","fixed":["1.27.0"],"introduced":["0"],"last_affected":[],"package":"modelscope","purl":null,"source":"GHSA-fhhq-h4hg-549x"},{"ecosystem":"PyPI","fixed":["1.27.0"],"introduced":["0"],"last_affected":[],"package":"modelscope","purl":"pkg:pypi/modelscope","source":"GHSA-fhhq-h4hg-549x"},{"ecosystem":"PyPI","fixed":["1.27.0"],"introduced":["0"],"last_affected":[],"package":"modelscope","purl":"pkg:pypi/modelscope","source":"PYSEC-2026-2663"}],"prev":{"headline":"File upload in n/a","id":"CVE-2025-51414"},"products":["n/a"],"published":"2026-05-19","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-15","vendors":["n/a"]},"summary":"Attackers can execute arbitrary code by crafting a malicious module entry in the configuration file, affecting ModelScope users.","url":"https://insights.sbomify.com/CVE-2025-51427/"}