CVE-2025-51487 moonshine Stored Cross-Site Scripting Vulnerability in Create Article

Medium 4.5 Published Updated

Attackers can execute arbitrary JavaScript via stored XSS in the CutCode Link parameter when creating or updating articles.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-51487?

CVE-2025-51487 is a medium-severity cross-site scripting vulnerability in n/a, published on 19 Aug 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

A Stored Cross-Site Scripting (XSS) vulnerability exists in MoonShine version < 3.12.5, allowing to execute arbitrary JavaScript by using "javascript:" payload, instead of the expected HTTPS protocol, in the CutCode Link parameter when creating/updating a new Article.

Weakness: CWE-79

Which versions are affected by CVE-2025-51487?

2 open source packages ship an affected version, including moonshine/moonshine. It affects 1 product.

PackageAffectedFixed in
moonshine/moonshine PackagistAll versions3.12.4
moonshine/moonshine PackagistAll versions3.12.4

Products include Moonshine Moonshine.

How do I fix CVE-2025-51487?

Upgrade moonshine/moonshine to 3.12.4 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2025-51487 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-51487 exists.

Sources

Also known as GHSA-p632-58pp-c9xg.

Is CVE-2025-51487 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free