{"answers":{"affected":"2 open source packages ship an affected version, including moonshine/moonshine. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-51487 exists.","fix":"Upgrade moonshine/moonshine to 3.12.4 or later.","what":"CVE-2025-51487 is a medium-severity cross-site scripting vulnerability in n/a, published on 19 Aug 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-51487 and fix it if it is affected.\n\nWhat it is: CVE-2025-51487 is a medium-severity cross-site scripting vulnerability in n/a, published on 19 Aug 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-51487 exists.\n\nAffected packages and fixed versions:\n- moonshine/moonshine (Packagist): affected all versions; fixed in 3.12.4\n- moonshine/moonshine (Packagist): affected all versions; fixed in 3.12.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-51487/ (Markdown: https://insights.sbomify.com/CVE-2025-51487/index.md)","id":"CVE-2025-51487","markdown":"https://insights.sbomify.com/CVE-2025-51487/index.md","name":"CVE-2025-51487","record":{"aliases":["GHSA-p632-58pp-c9xg"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"MoonShine admin panel","requires_auth":"high_privilege","summary":"Attackers can execute arbitrary JavaScript via stored XSS in the CutCode Link parameter when creating or updating articles.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"moonshine","vendor":"moonshine"}],"cvss":{"score":4.5,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A Stored Cross-Site Scripting (XSS) vulnerability exists in MoonShine version \u003c 3.12.5, allowing to execute arbitrary JavaScript by using \"javascript:\" payload, instead of the expected HTTPS protocol, in the CutCode Link parameter when creating/updating a new Article.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"moonshine Stored Cross-Site Scripting Vulnerability in Create Article","id":"CVE-2025-51487","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":2,"n_references":2,"next":{"headline":"moonshine Stored Cross-Site Scripting Vulnerability in Create Admin","id":"CVE-2025-51488"},"packages":[{"ecosystem":"Packagist","fixed":["3.12.4"],"introduced":["0"],"last_affected":[],"package":"moonshine/moonshine","purl":null,"source":"GHSA-p632-58pp-c9xg"},{"ecosystem":"Packagist","fixed":["3.12.4"],"introduced":["0"],"last_affected":[],"package":"moonshine/moonshine","purl":"pkg:composer/moonshine/moonshine","source":"GHSA-p632-58pp-c9xg"}],"prev":{"headline":"Code injection in n/a","id":"CVE-2025-51482"},"products":["n/a"],"published":"2025-08-19","related":[{"cvss_score":4.9,"headline":"moonshine Stored Cross-Site Scripting Vulnerability in Create Admin","id":"CVE-2025-51488","kev_date_added":null,"published":"2025-08-19"},{"cvss_score":4.5,"headline":"MoonShine Arbitrary File Upload Vulnerability","id":"CVE-2025-51489","kev_date_added":null,"published":"2025-08-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-08-20","vendors":["n/a"]},"summary":"Attackers can execute arbitrary JavaScript via stored XSS in the CutCode Link parameter when creating or updating articles.","url":"https://insights.sbomify.com/CVE-2025-51487/"}