# CVE-2025-51487: moonshine Stored Cross-Site Scripting Vulnerability in Create Article

> Attackers can execute arbitrary JavaScript via stored XSS in the CutCode Link parameter when creating or updating articles.

- **Severity:** Medium 4.5 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Aug 2025
- **Updated:** 20 Aug 2025
- **Also known as:** GHSA-p632-58pp-c9xg

## What is CVE-2025-51487?

CVE-2025-51487 is a medium-severity cross-site scripting vulnerability in n/a, published on 19 Aug 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

A Stored Cross-Site Scripting (XSS) vulnerability exists in MoonShine version < 3.12.5, allowing to execute arbitrary JavaScript by using "javascript:" payload, instead of the expected HTTPS protocol, in the CutCode Link parameter when creating/updating a new Article.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-51487?

2 open source packages ship an affected version, including moonshine/moonshine. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moonshine/moonshine` | Packagist | All versions | 3.12.4 |
| `moonshine/moonshine` | Packagist | All versions | 3.12.4 |

Products: Moonshine Moonshine.

## How do I fix CVE-2025-51487?

Upgrade moonshine/moonshine to 3.12.4 or later.

## Is CVE-2025-51487 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-51487 exists.

## Other vulnerabilities in n/a

- [CVE-2025-51488](https://insights.sbomify.com/CVE-2025-51488/): moonshine Stored Cross-Site Scripting Vulnerability in Create Admin (medium 4.9)
- [CVE-2025-51489](https://insights.sbomify.com/CVE-2025-51489/): MoonShine Arbitrary File Upload Vulnerability (medium 4.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-51487 and fix it if it is affected.

What it is: CVE-2025-51487 is a medium-severity cross-site scripting vulnerability in n/a, published on 19 Aug 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-51487 exists.

Affected packages and fixed versions:
- moonshine/moonshine (Packagist): affected all versions; fixed in 3.12.4
- moonshine/moonshine (Packagist): affected all versions; fixed in 3.12.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-51487/ (Markdown: https://insights.sbomify.com/CVE-2025-51487/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-51487
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-51487
- OSV: https://osv.dev/vulnerability/CVE-2025-51487

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-51487/
Summaries are generated and may contain mistakes; the official description above is the record.
