CVE-2025-51488 moonshine Stored Cross-Site Scripting Vulnerability in Create Admin

Medium 4.9 Published Updated

Remote attackers can execute arbitrary JavaScript via stored XSS in the Admin Name parameter, potentially compromising admin sessions.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-51488?

CVE-2025-51488 is a medium-severity cross-site scripting vulnerability in n/a, published on 19 Aug 2025. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

A Stored Cross-Site Scripting (XSS) vulnerability exists in MoonShine version < 3.12.4, allowing remote attackers to store and execute arbitrary JavaScript by including a malicious HTML payload in the Name parameter when creating a new Admin.

Weakness: CWE-79

Which versions are affected by CVE-2025-51488?

2 open source packages ship an affected version, including moonshine/moonshine. It affects 1 product.

PackageAffectedFixed in
moonshine/moonshine PackagistAll versions3.12.14
moonshine/moonshine PackagistAll versions3.12.14

Products include Moonshine Moonshine.

How do I fix CVE-2025-51488?

Upgrade moonshine/moonshine to 3.12.14 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2025-51488 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-51488 exists.

Sources

Also known as GHSA-rh9f-gr6q-mpc4.

Is CVE-2025-51488 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free