# CVE-2025-51586: Presta Shop vulnerable to email enumeration

> Attackers can gain sensitive information via the reset password feature in PrestaShop, requiring an upgrade to secure the application.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Sep 2025
- **Updated:** 8 Sep 2025
- **Also known as:** GHSA-8xx5-h6m3-jr33

## What is CVE-2025-51586?

CVE-2025-51586 is a low-severity vulnerability in Prestashop Prestashop, published on 8 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discoverd in file controllers/admin/AdminLoginController.php in PrestaShop before 8.2.1 allowing attackers to gain sensitive information via the reset password feature.

Weakness: CWE-359 (Exposure of Private Personal Information to an Unauthorized Actor)

## Which versions are affected by CVE-2025-51586?

2 open source packages ship an affected version, including prestashop/prestashop. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `prestashop/prestashop` | Packagist | All versions | 8.2.3 |
| `prestashop/prestashop` | Packagist | All versions | 8.2.3 |

Products: Prestashop Prestashop.

## How do I fix CVE-2025-51586?

Upgrade prestashop/prestashop to 8.2.3 or later.

## Is CVE-2025-51586 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-51586 exists.

Public exploit code:

- PrestaShop AdminLogin Email Enumeration PoC - CVE-2025-51586. This repository provides an ethical Proof-of-Concept (PoC) for the PrestaShop vulnerability allowing user enumeration through the AdminLogin password reset mechanism. It explains the impact, setup, and usage of the PoC script. (github_poc): https://github.com/7h30th3r0n3/CVE-2025-51586-PrestaShop-PoC
- PrestaShop - Information Disclosure (nuclei): http/cves/2025/CVE-2025-51586.yaml

## Other vulnerabilities in Prestashop Prestashop

- [CVE-2023-30839](https://insights.sbomify.com/CVE-2023-30839/): PrestaShop vulnerable to SQL filter bypass leading to arbitrary write requests using "SQL Manager" (critical 10.0)
- [CVE-2008-5791](https://insights.sbomify.com/CVE-2008-5791/): Other in n/a (critical 10.0)
- [CVE-2024-41651](https://insights.sbomify.com/CVE-2024-41651/): Server-side request forgery in n/a (critical 9.8)
- [CVE-2022-31181](https://insights.sbomify.com/CVE-2022-31181/): Remote code execution in prestashop (critical 9.8)
- [CVE-2021-3110](https://insights.sbomify.com/CVE-2021-3110/): SQL injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-51586 and fix it if it is affected.

What it is: CVE-2025-51586 is a low-severity vulnerability in Prestashop Prestashop, published on 8 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-51586 exists.

Affected packages and fixed versions:
- prestashop/prestashop (Packagist): affected all versions; fixed in 8.2.3
- prestashop/prestashop (Packagist): affected all versions; fixed in 8.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-51586/ (Markdown: https://insights.sbomify.com/CVE-2025-51586/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-51586
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-51586
- OSV: https://osv.dev/vulnerability/CVE-2025-51586

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-51586/
Summaries are generated and may contain mistakes; the official description above is the record.
