{"answers":{"affected":"3 open source packages ship an affected version, including pypickle. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-5174 exists.","fix":"Upgrade pypickle to 2.0.0 or later.","what":"CVE-2025-5174 is a medium-severity unsafe deserialization vulnerability in erdogant pypickle, published on 26 May 2025. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-5174 and fix it if it is affected.\n\nWhat it is: CVE-2025-5174 is a medium-severity unsafe deserialization vulnerability in erdogant pypickle, published on 26 May 2025. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-5174 exists.\n\nAffected packages and fixed versions:\n- pypickle (PyPI): affected all versions; fixed in 2.0.0\n- pypickle (PyPI): affected all versions; fixed in 2.0.0\n- pypickle (PyPI): affected all versions; fixed in 2.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-5174/ (Markdown: https://insights.sbomify.com/CVE-2025-5174/index.md)","id":"CVE-2025-5174","markdown":"https://insights.sbomify.com/CVE-2025-5174/index.md","name":"CVE-2025-5174","record":{"aliases":["GHSA-5qwj-342r-h886","PYSEC-2025-45"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Python pickle library","requires_auth":"low_privilege","summary":"A deserialization vulnerability in the pypickle library allows local attackers to execute arbitrary code via crafted pickle data.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"pypickle","vendor":"erdogant"}],"cvss":{"score":4.8,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"},{"id":"CWE-20","name":"Improper Input Validation"}],"description":"A vulnerability was found in erdogant pypickle up to 1.1.5 and classified as problematic. Affected by this issue is the function load of the file pypickle/pypickle.py. The manipulation leads to deserialization. Local access is required to approach this attack. The exploit has been disclosed to the public and may be used. Upgrading to version 2.0.0 is able to address this issue. The patch is identified as 14b4cae704a0bb4eb6723e238f25382d847a1917. It is recommended to upgrade the affected component.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"erdogant pypickle pypickle.py load deserialization","id":"CVE-2025-5174","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"deserialization","year":"2025"},"n_packages":3,"n_references":7,"next":{"headline":"erdogant pypickle pypickle.py save improper authorization","id":"CVE-2025-5175"},"packages":[{"ecosystem":"PyPI","fixed":["2.0.0"],"introduced":["0"],"last_affected":[],"package":"pypickle","purl":null,"source":"GHSA-5qwj-342r-h886"},{"ecosystem":"PyPI","fixed":["2.0.0"],"introduced":["0"],"last_affected":[],"package":"pypickle","purl":"pkg:pypi/pypickle","source":"GHSA-5qwj-342r-h886"},{"ecosystem":"PyPI","fixed":["2.0.0"],"introduced":["0"],"last_affected":[],"package":"pypickle","purl":"pkg:pypi/pypickle","source":"PYSEC-2025-45"}],"prev":{"headline":"HumanSignal label-studio-ml-backend PT File neural_nets.py load deserialization","id":"CVE-2025-5173"},"products":["pypickle"],"published":"2025-05-26","related":[{"cvss_score":4.8,"headline":"erdogant pypickle pypickle.py save improper authorization","id":"CVE-2025-5175","kev_date_added":null,"published":"2025-05-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-05-28","vendors":["erdogant"]},"summary":"A deserialization vulnerability in the pypickle library allows local attackers to execute arbitrary code via crafted pickle data.","url":"https://insights.sbomify.com/CVE-2025-5174/"}