CVE-2025-5175 erdogant pypickle pypickle.py save improper authorization

Medium 4.8 Published Updated

Local attackers can bypass authorization checks in the save function of the pypickle library, potentially escalating privileges.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2025-5175?

CVE-2025-5175 is a medium-severity missing authorization vulnerability in erdogant pypickle, published on 26 May 2025. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

A vulnerability was found in erdogant pypickle up to 1.1.5. It has been classified as critical. This affects the function Save of the file pypickle/pypickle.py. The manipulation leads to improper authorization. Attacking locally is a requirement. The exploit has been disclosed to the public and may be used. Upgrading to version 2.0.0 is able to address this issue. The patch is named 14b4cae704a0bb4eb6723e238f25382d847a1917. It is recommended to upgrade the affected component.

Weakness: CWE-285, CWE-266

Which versions are affected by CVE-2025-5175?

3 open source packages ship an affected version, including pypickle. It affects 1 product.

PackageAffectedFixed in
pypickle PyPIAll versions2.0.0
pypickle PyPIAll versions2.0.0
pypickle PyPIAll versions2.0.0

Products include Erdogant Pypickle.

How do I fix CVE-2025-5175?

Upgrade pypickle to 2.0.0 or later.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2025-5175 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-5175 exists.

Sources

Also known as GHSA-qpxx-2cwh-r5vh, PYSEC-2025-46.

Is CVE-2025-5175 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free