# CVE-2025-5175: erdogant pypickle pypickle.py save improper authorization

> Local attackers can bypass authorization checks in the save function of the pypickle library, potentially escalating privileges.

- **Severity:** Medium 4.8 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 May 2025
- **Updated:** 28 May 2025
- **Also known as:** GHSA-qpxx-2cwh-r5vh, PYSEC-2025-46

## What is CVE-2025-5175?

CVE-2025-5175 is a medium-severity missing authorization vulnerability in erdogant pypickle, published on 26 May 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability was found in erdogant pypickle up to 1.1.5. It has been classified as critical. This affects the function Save of the file pypickle/pypickle.py. The manipulation leads to improper authorization. Attacking locally is a requirement. The exploit has been disclosed to the public and may be used. Upgrading to version 2.0.0 is able to address this issue. The patch is named 14b4cae704a0bb4eb6723e238f25382d847a1917. It is recommended to upgrade the affected component.

Weakness: CWE-285 (Improper Authorization), CWE-266 (Incorrect Privilege Assignment)

## Which versions are affected by CVE-2025-5175?

3 open source packages ship an affected version, including pypickle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pypickle` | PyPI | All versions | 2.0.0 |
| `pypickle` | PyPI | All versions | 2.0.0 |
| `pypickle` | PyPI | All versions | 2.0.0 |

Products: Erdogant Pypickle.

## How do I fix CVE-2025-5175?

Upgrade pypickle to 2.0.0 or later.

## Is CVE-2025-5175 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-5175 exists.

## Other vulnerabilities in erdogant pypickle

- [CVE-2025-5174](https://insights.sbomify.com/CVE-2025-5174/): erdogant pypickle pypickle.py load deserialization (medium 4.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-5175 and fix it if it is affected.

What it is: CVE-2025-5175 is a medium-severity missing authorization vulnerability in erdogant pypickle, published on 26 May 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-5175 exists.

Affected packages and fixed versions:
- pypickle (PyPI): affected all versions; fixed in 2.0.0
- pypickle (PyPI): affected all versions; fixed in 2.0.0
- pypickle (PyPI): affected all versions; fixed in 2.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-5175/ (Markdown: https://insights.sbomify.com/CVE-2025-5175/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-5175
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-5175
- OSV: https://osv.dev/vulnerability/CVE-2025-5175

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-5175/
Summaries are generated and may contain mistakes; the official description above is the record.
