# CVE-2025-51825: JeecgBoot SQL Injection Vulnerability

> Attackers can execute arbitrary SQL commands via the parseSql endpoint, potentially reading or modifying database contents.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Aug 2025
- **Updated:** 22 Aug 2025
- **Also known as:** GHSA-gj8w-ffq9-6828

## What is CVE-2025-51825?

CVE-2025-51825 is a medium-severity SQL injection vulnerability in n/a, published on 22 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

JeecgBoot versions from 3.4.3 up to 3.8.0 were found to contain a SQL injection vulnerability in the /jeecg-boot/online/cgreport/head/parseSql endpoint, which allows bypassing SQL blacklist restrictions.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2025-51825?

2 open source packages ship an affected version, including org.jeecgframework.boot:jeecg-boot-base-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jeecgframework.boot:jeecg-boot-base-core` | Maven | From 3.4.3 | 3.8.1 |
| `org.jeecgframework.boot:jeecg-boot-base-core` | Maven | From 3.4.3 | 3.8.1 |

Products: Guojusoft Jeecgboot.

## How do I fix CVE-2025-51825?

Upgrade org.jeecgframework.boot:jeecg-boot-base-core to 3.8.1 or later.

## Is CVE-2025-51825 being exploited?

There is no known exploitation of CVE-2025-51825 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2024-57606](https://insights.sbomify.com/CVE-2024-57606/): SQL injection in JeecgBoot (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-51825 and fix it if it is affected.

What it is: CVE-2025-51825 is a medium-severity SQL injection vulnerability in n/a, published on 22 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-51825 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jeecgframework.boot:jeecg-boot-base-core (Maven): affected from 3.4.3; fixed in 3.8.1
- org.jeecgframework.boot:jeecg-boot-base-core (Maven): affected from 3.4.3; fixed in 3.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-51825/ (Markdown: https://insights.sbomify.com/CVE-2025-51825/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-51825
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-51825
- OSV: https://osv.dev/vulnerability/CVE-2025-51825

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-51825/
Summaries are generated and may contain mistakes; the official description above is the record.
