CVE-2025-5196 Wing FTP Server Lua Admin Console unnecessary privileges

High 7.5 Published Updated

Remote attackers can execute code with unnecessary privileges via the Lua Admin Console, requiring high complexity and admin access.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-5196?

CVE-2025-5196 is a high-severity vulnerability in Wing FTP Server, published on 26 May 2025. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

A vulnerability has been found in Wing FTP Server up to 7.4.3 and classified as critical. Affected by this vulnerability is an unknown functionality of the component Lua Admin Console. The manipulation leads to execution with unnecessary privileges. The attack can be launched remotely. The complexity of an attack is rather high. The exploitation appears to be difficult. Upgrading to version 7.4.4 is able to address this issue. It is recommended to upgrade the affected component. The vendor explains: "[W]e do not consider it as a security vulnerability, because the system admin in WingFTP has full permissions [...], but you can suggest the user run WingFTP service as Normal User rather than SYSTEM/Root, it will be safer."

Weakness: CWE-250

Which versions are affected by CVE-2025-5196?

It affects 1 product.

Products include Wftpserver Wing Ftp Server.

How do I fix CVE-2025-5196?

No fix has been published for CVE-2025-5196 yet. Limit exposure of the affected software until one is available.

Is CVE-2025-5196 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-5196 exists.

Public exploit code: 1 proofs of concept on GitHub.

Sources

Also known as GHSA-xh8q-jh7v-55g2.

Is CVE-2025-5196 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free