# CVE-2025-5196: Wing FTP Server Lua Admin Console unnecessary privileges

> Remote attackers can execute code with unnecessary privileges via the Lua Admin Console, requiring high complexity and admin access.

- **Severity:** High 7.5 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 26 May 2025
- **Updated:** 28 May 2025
- **Also known as:** GHSA-xh8q-jh7v-55g2

## What is CVE-2025-5196?

CVE-2025-5196 is a high-severity vulnerability in Wing FTP Server, published on 26 May 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

A vulnerability has been found in Wing FTP Server up to 7.4.3 and classified as critical. Affected by this vulnerability is an unknown functionality of the component Lua Admin Console. The manipulation leads to execution with unnecessary privileges. The attack can be launched remotely. The complexity of an attack is rather high. The exploitation appears to be difficult. Upgrading to version 7.4.4 is able to address this issue. It is recommended to upgrade the affected component. The vendor explains: "[W]e do not consider it as a security vulnerability, because the system admin in WingFTP has full permissions [...], but you can suggest the user run WingFTP service as Normal User rather than SYSTEM/Root, it will be safer."

Weakness: CWE-250 (Execution with Unnecessary Privileges)

## Which versions are affected by CVE-2025-5196?

It affects 1 product.


Products: Wftpserver Wing Ftp Server.

## How do I fix CVE-2025-5196?

No fix has been published for CVE-2025-5196 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-5196 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-5196 exists.

Public exploit code:

- Wing FTP Server provides an administrative Lua scripting console accessible via its web interface. Authenticated administrators are able to execute arbitrary Lua code with insufficient sandboxing. CVE-2025-5196 (github_poc): https://github.com/Nouvexr/Wing-FTP-Server-7.4.4-RCE-Authenticated

## Other vulnerabilities in Wing FTP Server

- [CVE-2025-47812](https://insights.sbomify.com/CVE-2025-47812/): Wing FTP Server Improper Neutralization of Null Byte or NUL Character (critical 10.0, exploited in the wild)
- [CVE-2025-47813](https://insights.sbomify.com/CVE-2025-47813/): Wing FTP Server Information Disclosure (medium 4.3, exploited in the wild)
- [CVE-2026-44403](https://insights.sbomify.com/CVE-2026-44403/): Wing FTP Server < 8.1.3 Authenticated Remote Code Execution via Session Serialization (high 8.6)
- [CVE-2020-37032](https://insights.sbomify.com/CVE-2020-37032/): Wing FTP Server 6.3.8 - Remote Code Execution (high 8.6)
- [CVE-2019-25267](https://insights.sbomify.com/CVE-2019-25267/): Wing FTP Server 6.0.7 - Unquoted Service Path (high 8.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-5196 and fix it if it is affected.

What it is: CVE-2025-5196 is a high-severity vulnerability in Wing FTP Server, published on 26 May 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-5196 exists.

Affected product: Wing FTP Server. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-5196/ (Markdown: https://insights.sbomify.com/CVE-2025-5196/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-5196
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-5196
- OSV: https://osv.dev/vulnerability/CVE-2025-5196

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-5196/
Summaries are generated and may contain mistakes; the official description above is the record.
