# CVE-2025-5197: Regular Expression Denial of Service (ReDoS) in huggingface/transformers

> Attackers can cause service disruption and resource exhaustion in Hugging Face Transformers via crafted input triggering catastrophic regex backtracking.

- **Severity:** Medium 5.3 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Aug 2025
- **Updated:** 6 Aug 2025
- **Also known as:** GHSA-9356-575x-2w9m, PYSEC-2026-1983

## What is CVE-2025-5197?

CVE-2025-5197 is a medium-severity denial of service vulnerability in huggingface/transformers, published on 6 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A Regular Expression Denial of Service (ReDoS) vulnerability exists in the Hugging Face Transformers library, specifically in the `convert_tf_weight_name_to_pt_weight_name()` function. This function, responsible for converting TensorFlow weight names to PyTorch format, uses a regex pattern `/[^/]*___([^/]*)/` that can be exploited to cause excessive CPU consumption through crafted input strings due to catastrophic backtracking. The vulnerability affects versions up to 4.51.3 and is fixed in version 4.53.0. This issue can lead to service disruption, resource exhaustion, and potential API service vulnerabilities, impacting model conversion processes between TensorFlow and PyTorch formats.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2025-5197?

3 open source packages ship an affected version, including transformers. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `transformers` | PyPI | All versions | 4.53.0 |
| `transformers` | PyPI | All versions | 4.53.0 |
| `transformers` | PyPI | All versions | 4.53.0 |

Products: Huggingface Transformers.

## How do I fix CVE-2025-5197?

Upgrade transformers to 4.53.0 or later.

## Is CVE-2025-5197 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-5197 exists.

## Other vulnerabilities in huggingface/transformers

- [CVE-2023-7018](https://insights.sbomify.com/CVE-2023-7018/): Deserialization of Untrusted Data in huggingface/transformers (critical 9.6)
- [CVE-2023-6730](https://insights.sbomify.com/CVE-2023-6730/): Deserialization of Untrusted Data in huggingface/transformers (critical 9.0)
- [CVE-2024-11393](https://insights.sbomify.com/CVE-2024-11393/): Hugging Face Transformers MaskFormer Model Deserialization of Untrusted Data Remote Code Execution Vulnerability (high 8.8)
- [CVE-2024-11394](https://insights.sbomify.com/CVE-2024-11394/): Hugging Face Transformers Trax Model Deserialization of Untrusted Data Remote Code Execution Vulnerability (high 8.8)
- [CVE-2026-5241](https://insights.sbomify.com/CVE-2026-5241/): Policy Bypass in LightGlue Nested Config Resolution in huggingface/transformers (high 8.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-5197 and fix it if it is affected.

What it is: CVE-2025-5197 is a medium-severity denial of service vulnerability in huggingface/transformers, published on 6 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-5197 exists.

Affected packages and fixed versions:
- transformers (PyPI): affected all versions; fixed in 4.53.0
- transformers (PyPI): affected all versions; fixed in 4.53.0
- transformers (PyPI): affected all versions; fixed in 4.53.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-5197/ (Markdown: https://insights.sbomify.com/CVE-2025-5197/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-5197
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-5197
- OSV: https://osv.dev/vulnerability/CVE-2025-5197

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-5197/
Summaries are generated and may contain mistakes; the official description above is the record.
