# CVE-2025-52434: Apache Tomcat: APR/Native Connector crash leading to DoS

> A race condition in the APR/Native connector allows attackers to cause a denial of service via HTTP/2 connection closes.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jul 2025
- **Updated:** 4 Nov 2025
- **Also known as:** BIT-tomcat-2025-52434, CLSA-2026-1771891820, CLSA-2026-1771978232, CLSA-2026-1779805268, CLSA-2026-1780274968, DEBIAN-CVE-2025-52434, GHSA-4j3c-42xv-3f84, MINI-m2rv-5cx3-9cc2, MINI-q99c-7xc5-f8vw, UBUNTU-CVE-2025-52434

## What is CVE-2025-52434?

CVE-2025-52434 is a high-severity vulnerability in Apache Tomcat, published on 10 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Concurrent Execution using Shared Resource with Improper Synchronization ('Race Condition') vulnerability in Apache Tomcat when using the APR/Native connector. This was particularly noticeable with client initiated closes of HTTP/2 connections.

This issue affects Apache Tomcat: from 9.0.0.M1 through 9.0.106.
The following versions were EOL at the time the CVE was created but are 
known to be affected: 8.5.0 through 8.5.100. Other, older, EOL versions 
may also be affected.

Users are recommended to upgrade to version 9.0.107, which fixes the issue.

Weakness: CWE-362 (Concurrent Execution using Shared Resource with Improper Synchronization)

## Which versions are affected by CVE-2025-52434?

9 open source packages ship an affected version, including org.apache.tomcat.embed:tomcat-embed-core, tomcat and org.apache.tomcat:tomcat-coyote. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 8.5.0 to 8.5.100 | None |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 8.5.0 to 8.5.100 | None |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 9.0.0.M1 | 9.0.107 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 9.0.0.M1 | 9.0.107 |
| `tomcat` | Bitnami | From 9.0.0 | 9.0.107 |
| `org.apache.tomcat:tomcat-coyote` | Maven | From 8.5.0 to 8.5.100 | None |
| `org.apache.tomcat:tomcat-coyote` | Maven | From 8.5.0 to 8.5.100 | None |
| `org.apache.tomcat:tomcat-coyote` | Maven | From 9.0.0.M1 | 9.0.107 |
| `org.apache.tomcat:tomcat-coyote` | Maven | From 9.0.0.M1 | 9.0.107 |

Products: Apache Tomcat.

## How do I fix CVE-2025-52434?

Upgrade org.apache.tomcat.embed:tomcat-embed-core to 9.0.107 or later.

## Is CVE-2025-52434 being exploited?

There is no known exploitation of CVE-2025-52434 in the wild and no public exploit code.

## Other vulnerabilities in Apache Tomcat

- [CVE-2025-24813](https://insights.sbomify.com/CVE-2025-24813/): Apache Tomcat Path Equivalence (critical 10.0, exploited in the wild)
- [CVE-2016-8735](https://insights.sbomify.com/CVE-2016-8735/): Apache Tomcat Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-12617](https://insights.sbomify.com/CVE-2017-12617/): Apache Tomcat Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2017-12615](https://insights.sbomify.com/CVE-2017-12615/): Apache Tomcat on Windows Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2026-34486](https://insights.sbomify.com/CVE-2026-34486/): Apache Tomcat Missing Encryption of Sensitive Data (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-52434 and fix it if it is affected.

What it is: CVE-2025-52434 is a high-severity vulnerability in Apache Tomcat, published on 10 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-52434 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 8.5.0 up to 8.5.100; no fix listed
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 8.5.0 up to 8.5.100; no fix listed
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 9.0.0.M1; fixed in 9.0.107
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 9.0.0.M1; fixed in 9.0.107
- tomcat (Bitnami): affected from 9.0.0; fixed in 9.0.107
- org.apache.tomcat:tomcat-coyote (Maven): affected from 8.5.0 up to 8.5.100; no fix listed
- org.apache.tomcat:tomcat-coyote (Maven): affected from 8.5.0 up to 8.5.100; no fix listed
- org.apache.tomcat:tomcat-coyote (Maven): affected from 9.0.0.M1; fixed in 9.0.107
- org.apache.tomcat:tomcat-coyote (Maven): affected from 9.0.0.M1; fixed in 9.0.107

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-52434/ (Markdown: https://insights.sbomify.com/CVE-2025-52434/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-52434
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-52434
- OSV: https://osv.dev/vulnerability/CVE-2025-52434

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-52434/
Summaries are generated and may contain mistakes; the official description above is the record.
