# CVE-2025-52435: Apache Mynewt NimBLE: Invalid error handling in pause encryption procedure in NimBLE controller

> An attacker can eavesdrop on Bluetooth Low Energy communications due to improper handling of encryption pause procedures in Apache NimBLE.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 10 Jan 2026
- **Updated:** 12 Jan 2026
- **Also known as:** GHSA-5c5p-g26h-xx2f

## What is CVE-2025-52435?

CVE-2025-52435 is a high-severity vulnerability in Apache Mynewt NimBLE, published on 10 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

J2EE Misconfiguration: Data Transmission Without Encryption vulnerability in Apache NimBLE.

Improper handling of Pause Encryption procedure on Link Layer results in a previously encrypted connection being left in un-encrypted state allowing an eavesdropper to observe the remainder of the exchange.
This issue affects Apache NimBLE: through <= 1.8.0.

Users are recommended to upgrade to version 1.9.0, which fixes the issue.

Weakness: CWE-5 (J2EE Misconfiguration: Data Transmission Without Encryption)

## Which versions are affected by CVE-2025-52435?

It affects 1 product.


Products: Apache Nimble.

## How do I fix CVE-2025-52435?

No fix has been published for CVE-2025-52435 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-52435 being exploited?

There is no known exploitation of CVE-2025-52435 in the wild and no public exploit code.

## Other vulnerabilities in Apache Mynewt NimBLE

- [CVE-2026-45813](https://insights.sbomify.com/CVE-2026-45813/): Apache NimBLE: Incorrect data validation in BASS add/modify source operation (high 8.8)
- [CVE-2025-62235](https://insights.sbomify.com/CVE-2025-62235/): Apache Mynewt NimBLE: Incorrect handling of SMP Security Request could lead to undesirable pairing (high 8.1)
- [CVE-2026-45811](https://insights.sbomify.com/CVE-2026-45811/): Apache NimBLE: Buffer overflow in socket HCI transport (high 7.5)
- [CVE-2026-45815](https://insights.sbomify.com/CVE-2026-45815/): Apache NimBLE: Remote reachable assertion in ATT Read Multiple Variable Response handler (high 7.5)
- [CVE-2026-45816](https://insights.sbomify.com/CVE-2026-45816/): Apache NimBLE: NULL pointer dereference vulnerability in SMP LTK request (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-52435 and fix it if it is affected.

What it is: CVE-2025-52435 is a high-severity vulnerability in Apache Mynewt NimBLE, published on 10 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-52435 in the wild and no public exploit code.

Affected product: Apache Mynewt NimBLE. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-52435/ (Markdown: https://insights.sbomify.com/CVE-2025-52435/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-52435
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-52435
- OSV: https://osv.dev/vulnerability/CVE-2025-52435

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-52435/
Summaries are generated and may contain mistakes; the official description above is the record.
