# CVE-2025-5244: GNU Binutils ld elflink.c elf_gc_sweep memory corruption

> A local attacker can exploit memory corruption in the GNU Binutils linker to potentially execute arbitrary code.

- **Severity:** Medium 4.8 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 May 2025
- **Updated:** 15 Oct 2026
- **Also known as:** ALPINE-CVE-2025-5244, ALSA-2025:20155, AZL-61982, AZL-61994, AZL-62047, BELL-CVE-2025-5244, DEBIAN-CVE-2025-5244, ECHO-f8c4-e042-8153, GHSA-3c6j-3hg7-vq95, MINI-rwmp-4p84-x5mc, RHSA-2025:20155, RLSA-2025:20155, ROOT-OS-ALPINE-319-CVE-2025-5244, ROOT-OS-ALPINE-321-CVE-2025-5244, ROOT-OS-DEBIAN-12-CVE-2025-5244, UBUNTU-CVE-2025-5244

## What is CVE-2025-5244?

CVE-2025-5244 is a medium-severity memory corruption vulnerability in Gnu Binutils, published on 27 May 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability was found in GNU Binutils up to 2.44. It has been rated as critical. Affected by this issue is the function elf_gc_sweep of the file bfd/elflink.c of the component ld. The manipulation leads to memory corruption. An attack has to be approached locally. The exploit has been disclosed to the public and may be used. Upgrading to version 2.45 is able to address this issue. It is recommended to upgrade the affected component.

Weakness: CWE-119 (Improper Restriction of Operations within the Bounds of a Memory Buffer)

## Which versions are affected by CVE-2025-5244?

It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `binutils` | AlmaLinux:10 | All versions | 2.41-58.el10.alma.1 |
| `binutils-devel` | AlmaLinux:10 | All versions | 2.41-58.el10.alma.1 |
| `binutils-gold` | AlmaLinux:10 | All versions | 2.41-58.el10.alma.1 |
| `binutils` | Red Hat:enterprise_linux:10.1 | All versions | 0:2.41-58.el10 |
| `binutils-debuginfo` | Red Hat:enterprise_linux:10.1 | All versions | 0:2.41-58.el10 |
| `binutils-debugsource` | Red Hat:enterprise_linux:10.1 | All versions | 0:2.41-58.el10 |
| `binutils-devel` | Red Hat:enterprise_linux:10.1 | All versions | 0:2.41-58.el10 |
| `binutils-gold` | Red Hat:enterprise_linux:10.1 | All versions | 0:2.41-58.el10 |
| `binutils-gold-debuginfo` | Red Hat:enterprise_linux:10.1 | All versions | 0:2.41-58.el10 |
| `binutils-gprofng-debuginfo` | Red Hat:enterprise_linux:10.1 | All versions | 0:2.41-58.el10 |
| `cross-binutils-aarch64-debuginfo` | Red Hat:enterprise_linux:10.1 | All versions | 0:2.41-58.el10 |
| `cross-binutils-ppc64le-debuginfo` | Red Hat:enterprise_linux:10.1 | All versions | 0:2.41-58.el10 |
| `cross-binutils-s390x-debuginfo` | Red Hat:enterprise_linux:10.1 | All versions | 0:2.41-58.el10 |
| `binutils` | Rocky Linux:10 | All versions | 0:2.41-58.el10 |

Products: Gnu Binutils.

## How do I fix CVE-2025-5244?

Upgrade to a fixed version.

## Is CVE-2025-5244 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-5244 exists.

## Other vulnerabilities in Gnu Binutils

- [CVE-2017-7614](https://insights.sbomify.com/CVE-2017-7614/): Null dereference in n/a (critical 9.8)
- [CVE-2014-9939](https://insights.sbomify.com/CVE-2014-9939/): Memory corruption in n/a (critical 9.8)
- [CVE-2017-7226](https://insights.sbomify.com/CVE-2017-7226/): Information disclosure in n/a (critical 9.1)
- [CVE-2017-6969](https://insights.sbomify.com/CVE-2017-6969/): Information disclosure in n/a (critical 9.1)
- [CVE-2020-19726](https://insights.sbomify.com/CVE-2020-19726/): Denial of service in n/a (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-5244 and fix it if it is affected.

What it is: CVE-2025-5244 is a medium-severity memory corruption vulnerability in Gnu Binutils, published on 27 May 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-5244 exists.

Affected product: Gnu Binutils. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-5244/ (Markdown: https://insights.sbomify.com/CVE-2025-5244/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-5244
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-5244
- OSV: https://osv.dev/vulnerability/CVE-2025-5244

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-5244/
Summaries are generated and may contain mistakes; the official description above is the record.
