CVE-2025-52465 GeoServer has an arbitrary file write vulnerability in its Master Password Dump Page
Authenticated administrators can write arbitrary files containing the master password, potentially leading to data exposure or code execution.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-52465?
CVE-2025-52465 is a high-severity path traversal vulnerability in org.geoserver.web:gs-web-app, published on 18 Jun 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
GeoServer is an open source server that allows users to share and edit geospatial data. Prior to versions 2.26.4 and 2.27.3, a vulnerability exists that allows an authenticated administrator with access to GeoServer's security system to pass arbitrary file names to the Master Password Dump web page and create files containing the master password in plaintext. The provided file name must be an absolute path to the target file, the target file can not already exist and all parent directories must already exist. Versions 2.26.4 and 2.27.3 contain a fix. GeoServer installations where the web interface is either disabled or completely removed are not affected since the vulnerability exists in one of the web pages.
Weakness: CWE-73
Which versions are affected by CVE-2025-52465?
8 open source packages ship an affected version, including org.geoserver.web:gs-web-app and org.geoserver.web:gs-web-sec-core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.geoserver.web:gs-web-app Maven | All versions | 2.26.4 |
org.geoserver.web:gs-web-app Maven | All versions | 2.26.4 |
org.geoserver.web:gs-web-app Maven | From 2.27.0 | 2.27.3 |
org.geoserver.web:gs-web-app Maven | From 2.27.0 | 2.27.3 |
org.geoserver.web:gs-web-sec-core Maven | All versions | 2.26.4 |
org.geoserver.web:gs-web-sec-core Maven | All versions | 2.26.4 |
2 more packages
org.geoserver.web:gs-web-sec-core Maven | From 2.27.0 | 2.27.3 |
org.geoserver.web:gs-web-sec-core Maven | From 2.27.0 | 2.27.3 |
Products include Osgeo Geoserver.
How do I fix CVE-2025-52465?
Upgrade org.geoserver.web:gs-web-app to a fixed version for your release line: 2.26.4 or 2.27.3.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2025-52465 being exploited?
There is no known exploitation of CVE-2025-52465 in the wild and no public exploit code.
Other vulnerabilities in org.geoserver.web:gs-web-app
- CVE-2023-25157 Unfiltered SQL Injection Vulnerabilities in Geoserver
- CVE-2024-34711 GeoServer has improper ENTITY_RESOLUTION_ALLOWLIST URI validation in XML Processing (SSRF)
- CVE-2023-41339 Unsecured WMS dynamic styling sld=<url> parameter affords blind unauthenticated SSRF in GeoServer
- CVE-2023-43795 WPS Server Side Request Forgery in GeoServer
- CVE-2024-29198 GeoServer Vulnerable to Unauthenticated SSRF via TestWfsPost
Sources
Also known as GHSA-7qmg-grcp-qf25.