# CVE-2025-52465: GeoServer has an arbitrary file write vulnerability in its Master Password Dump Page

> Authenticated administrators can write arbitrary files containing the master password, potentially leading to data exposure or code execution.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Jun 2026
- **Updated:** 24 Jun 2026
- **Also known as:** GHSA-7qmg-grcp-qf25

## What is CVE-2025-52465?

CVE-2025-52465 is a high-severity path traversal vulnerability in org.geoserver.web:gs-web-app, published on 18 Jun 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

GeoServer is an open source server that allows users to share and edit geospatial data. Prior to versions 2.26.4 and 2.27.3, a vulnerability exists that allows an authenticated administrator with access to GeoServer's security system to pass arbitrary file names to the Master Password Dump web page and create files containing the master password in plaintext. The provided file name must be an absolute path to the target file, the target file can not already exist and all parent directories must already exist. Versions 2.26.4 and 2.27.3 contain a fix. GeoServer installations where the web interface is either disabled or completely removed are not affected since the vulnerability exists in one of the web pages.

Weakness: CWE-73 (External Control of File Name or Path)

## Which versions are affected by CVE-2025-52465?

8 open source packages ship an affected version, including org.geoserver.web:gs-web-app and org.geoserver.web:gs-web-sec-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.geoserver.web:gs-web-app` | Maven | All versions | 2.26.4 |
| `org.geoserver.web:gs-web-app` | Maven | All versions | 2.26.4 |
| `org.geoserver.web:gs-web-app` | Maven | From 2.27.0 | 2.27.3 |
| `org.geoserver.web:gs-web-app` | Maven | From 2.27.0 | 2.27.3 |
| `org.geoserver.web:gs-web-sec-core` | Maven | All versions | 2.26.4 |
| `org.geoserver.web:gs-web-sec-core` | Maven | All versions | 2.26.4 |
| `org.geoserver.web:gs-web-sec-core` | Maven | From 2.27.0 | 2.27.3 |
| `org.geoserver.web:gs-web-sec-core` | Maven | From 2.27.0 | 2.27.3 |

Products: Osgeo Geoserver.

## How do I fix CVE-2025-52465?

Upgrade org.geoserver.web:gs-web-app to a fixed version for your release line: 2.26.4 or 2.27.3.

## Is CVE-2025-52465 being exploited?

There is no known exploitation of CVE-2025-52465 in the wild and no public exploit code.

## Other vulnerabilities in org.geoserver.web:gs-web-app

- [CVE-2023-25157](https://insights.sbomify.com/CVE-2023-25157/): Unfiltered SQL Injection Vulnerabilities in Geoserver (critical 9.8)
- [CVE-2024-34711](https://insights.sbomify.com/CVE-2024-34711/): GeoServer has improper ENTITY_RESOLUTION_ALLOWLIST URI validation in XML Processing (SSRF) (critical 9.3)
- [CVE-2023-41339](https://insights.sbomify.com/CVE-2023-41339/): Unsecured WMS dynamic styling sld=<url> parameter affords blind unauthenticated SSRF in GeoServer (high 8.6)
- [CVE-2023-43795](https://insights.sbomify.com/CVE-2023-43795/): WPS Server Side Request Forgery in GeoServer (high 8.6)
- [CVE-2024-29198](https://insights.sbomify.com/CVE-2024-29198/): GeoServer Vulnerable to Unauthenticated SSRF via TestWfsPost (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-52465 and fix it if it is affected.

What it is: CVE-2025-52465 is a high-severity path traversal vulnerability in org.geoserver.web:gs-web-app, published on 18 Jun 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-52465 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.geoserver.web:gs-web-app (Maven): affected all versions; fixed in 2.26.4
- org.geoserver.web:gs-web-app (Maven): affected all versions; fixed in 2.26.4
- org.geoserver.web:gs-web-app (Maven): affected from 2.27.0; fixed in 2.27.3
- org.geoserver.web:gs-web-app (Maven): affected from 2.27.0; fixed in 2.27.3
- org.geoserver.web:gs-web-sec-core (Maven): affected all versions; fixed in 2.26.4
- org.geoserver.web:gs-web-sec-core (Maven): affected all versions; fixed in 2.26.4
- org.geoserver.web:gs-web-sec-core (Maven): affected from 2.27.0; fixed in 2.27.3
- org.geoserver.web:gs-web-sec-core (Maven): affected from 2.27.0; fixed in 2.27.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-52465/ (Markdown: https://insights.sbomify.com/CVE-2025-52465/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-52465
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-52465
- OSV: https://osv.dev/vulnerability/CVE-2025-52465

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-52465/
Summaries are generated and may contain mistakes; the official description above is the record.
