CVE-2025-52478 Stored XSS in n8n Form Trigger allows Account Takeover via injected iframe and video/source

High 8.7 Published Updated

Authenticated attackers can inject malicious HTML into n8n Form Triggers to steal session cookies and take over user accounts.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-52478?

CVE-2025-52478 is a high-severity cross-site scripting vulnerability in N8n N8n, published on 19 Aug 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

n8n is a workflow automation platform. From 1.77.0 to before 1.98.2, a stored Cross-Site Scripting (XSS) vulnerability was identified in n8n, specifically in the Form Trigger node's HTML form element. An authenticated attacker can inject malicious HTML via an <iframe> with a srcdoc payload that includes arbitrary JavaScript execution. The attacker can also inject malicious Javascript by using <video> coupled <source> using an onerror event. While using iframe or a combination of video and source tag, this vulnerability allows for Account Takeover (ATO) by exfiltrating n8n-browserId and session cookies from authenticated users who visit a maliciously crafted form. Using these tokens and cookies, an attacker can impersonate the victim and change account details such as email addresses, enabling full control over the account—especially if 2FA is not enabled. Users should upgrade to version >= 1.98.2.

Weakness: CWE-79

Which versions are affected by CVE-2025-52478?

2 open source packages ship an affected version, including n8n. It affects 1 product.

PackageAffectedFixed in
n8n npmFrom 1.77.01.98.2
n8n npmFrom 1.77.01.98.2

Products include N8n N8n.

How do I fix CVE-2025-52478?

Upgrade n8n to 1.98.2 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2025-52478 being exploited?

There is no known exploitation of CVE-2025-52478 in the wild and no public exploit code.

All N8n N8n vulnerabilities

Sources

Also known as GHSA-hfmv-hhh3-43f2.

Is CVE-2025-52478 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free