# CVE-2025-52478: Stored XSS in n8n Form Trigger allows Account Takeover via injected iframe and video/source

> Authenticated attackers can inject malicious HTML into n8n Form Triggers to steal session cookies and take over user accounts.

- **Severity:** High 8.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Aug 2025
- **Updated:** 19 Aug 2025
- **Also known as:** GHSA-hfmv-hhh3-43f2

## What is CVE-2025-52478?

CVE-2025-52478 is a high-severity cross-site scripting vulnerability in N8n N8n, published on 19 Aug 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

n8n is a workflow automation platform. From 1.77.0 to before 1.98.2, a stored Cross-Site Scripting (XSS) vulnerability was identified in n8n, specifically in the Form Trigger node's HTML form element. An authenticated attacker can inject malicious HTML via an <iframe> with a srcdoc payload that includes arbitrary JavaScript execution. The attacker can also inject malicious Javascript by using <video> coupled <source> using an onerror event. While using iframe or a combination of video and source tag, this vulnerability allows for Account Takeover (ATO) by exfiltrating n8n-browserId and session cookies from authenticated users who visit a maliciously crafted form. Using these tokens and cookies, an attacker can impersonate the victim and change account details such as email addresses, enabling full control over the account—especially if 2FA is not enabled. Users should upgrade to version >= 1.98.2.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-52478?

2 open source packages ship an affected version, including n8n. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `n8n` | npm | From 1.77.0 | 1.98.2 |
| `n8n` | npm | From 1.77.0 | 1.98.2 |

Products: N8n N8n.

## How do I fix CVE-2025-52478?

Upgrade n8n to 1.98.2 or later.

## Is CVE-2025-52478 being exploited?

There is no known exploitation of CVE-2025-52478 in the wild and no public exploit code.

## Other vulnerabilities in N8n N8n

- [CVE-2025-68613](https://insights.sbomify.com/CVE-2025-68613/): n8n Improper Control of Dynamically-Managed Code Resources (critical 10.0, exploited in the wild)
- [CVE-2026-21877](https://insights.sbomify.com/CVE-2026-21877/): n8n is vulnerable to Remote Code Execution via Arbitrary File Write (critical 10.0)
- [CVE-2026-21858](https://insights.sbomify.com/CVE-2026-21858/): n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling (critical 10.0)
- [CVE-2026-1470](https://insights.sbomify.com/CVE-2026-1470/): n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution (critical 9.9)
- [CVE-2025-68668](https://insights.sbomify.com/CVE-2025-68668/): n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-52478 and fix it if it is affected.

What it is: CVE-2025-52478 is a high-severity cross-site scripting vulnerability in N8n N8n, published on 19 Aug 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-52478 in the wild and no public exploit code.

Affected packages and fixed versions:
- n8n (npm): affected from 1.77.0; fixed in 1.98.2
- n8n (npm): affected from 1.77.0; fixed in 1.98.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-52478/ (Markdown: https://insights.sbomify.com/CVE-2025-52478/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-52478
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-52478
- OSV: https://osv.dev/vulnerability/CVE-2025-52478

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-52478/
Summaries are generated and may contain mistakes; the official description above is the record.
