# CVE-2025-52482: Cross-site scripting in chamilo-lms

> Teachers can inject malicious JavaScript into the glossary, potentially compromising administrator accounts in Chamilo LMS.

- **Severity:** High 8.3 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 2 Mar 2026
- **Updated:** 2 Mar 2026
- **Also known as:** GHSA-4wcp-3rh3-7wm4

## What is CVE-2025-52482?

CVE-2025-52482 is a high-severity cross-site scripting vulnerability in Chamilo Chamilo Lms, published on 2 Mar 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Chamilo is a learning management system. Prior to version 1.11.30, a Stored XSS vulnerability exists in the glossary function, enabling all users with the Teachers role to inject JavaScript malicious code against the administrator. This issue has been patched in version 1.11.30.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-52482?

It affects 1 product.


Products: Chamilo Chamilo Lms.

## How do I fix CVE-2025-52482?

No fix has been published for CVE-2025-52482 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-52482 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-52482 exists.

## Other vulnerabilities in Chamilo Chamilo Lms

- [CVE-2025-50187](https://insights.sbomify.com/CVE-2025-50187/): Chamilo: Evaluation of untrusted user input leads to Remote Code Execution (critical 9.8)
- [CVE-2023-34944](https://insights.sbomify.com/CVE-2023-34944/): File upload in n/a (critical 9.8)
- [CVE-2022-27423](https://insights.sbomify.com/CVE-2022-27423/): SQL injection in n/a (critical 9.8)
- [CVE-2021-35414](https://insights.sbomify.com/CVE-2021-35414/): SQL injection in n/a (critical 9.8)
- [CVE-2019-13082](https://insights.sbomify.com/CVE-2019-13082/): File upload in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-52482 and fix it if it is affected.

What it is: CVE-2025-52482 is a high-severity cross-site scripting vulnerability in Chamilo Chamilo Lms, published on 2 Mar 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-52482 exists.

Affected product: Chamilo Chamilo Lms. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-52482/ (Markdown: https://insights.sbomify.com/CVE-2025-52482/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-52482
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-52482
- OSV: https://osv.dev/vulnerability/CVE-2025-52482

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-52482/
Summaries are generated and may contain mistakes; the official description above is the record.
