{"answers":{"affected":"4 open source packages ship an affected version, including risc0-circuit-rv32im and risc0-zkvm.","exploited":"There is no known exploitation of CVE-2025-52484 in the wild and no public exploit code.","fix":"Upgrade risc0-circuit-rv32im to 2.0.4 or later.","what":"CVE-2025-52484 is a low-severity vulnerability in risc0, published on 20 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-52484 and fix it if it is affected.\n\nWhat it is: CVE-2025-52484 is a low-severity vulnerability in risc0, published on 20 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-52484 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- risc0-circuit-rv32im (crates.io): affected from 2.0.0; fixed in 2.0.4\n- risc0-circuit-rv32im (crates.io): affected from 2.0.0; fixed in 2.0.4\n- risc0-zkvm (crates.io): affected from 2.0.0; fixed in 2.1.0\n- risc0-zkvm (crates.io): affected from 2.0.0; fixed in 2.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-52484/ (Markdown: https://insights.sbomify.com/CVE-2025-52484/index.md)","id":"CVE-2025-52484","markdown":"https://insights.sbomify.com/CVE-2025-52484/index.md","name":"CVE-2025-52484","record":{"aliases":["GHSA-g3qg-6746-3mg9"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"RISC Zero zkVM library","requires_auth":"none","summary":"A malicious prover can bypass verification constraints in the RISC Zero zkVM library, allowing invalid proofs to be accepted as valid.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":2.7,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:U","version":"4.0"},"cwes":[{"id":"CWE-345","name":"Insufficient Verification of Data Authenticity"}],"description":"RISC Zero is a general computing platform based on zk-STARKs and the RISC-V microarchitecture. Due to a missing constraint in the rv32im circuit, any 3-register RISC-V instruction (including remu and divu) in risc0-zkvm 2.0.0, 2.0.1, and 2.0.2 are vulnerable to an attack by a malicious prover. The main idea for the attack is to confuse the RISC-V virtual machine into treating the value of the rs1 register as the same as the rs2 register due to a lack of constraints in the rv32im circuit. Rust applications using the risc0-zkvm crate at versions 2.0.0, 2.0.1, and 2.0.2 should upgrade to version 2.1.0. Smart contract applications using the official RISC Zero Verifier Router do not need to take any action: zkVM version 2.1 is active on all official routers, and version 2.0 has been disabled. Smart contract applications not using the verifier router should update their contracts to send verification calls to the 2.1 version of the verifier.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"RISC Zero zkVM Underconstrained Vulnerability","id":"CVE-2025-52484","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"other","year":"2025"},"n_packages":4,"n_references":7,"next":{"headline":"DNN.PLATFORM Allows Stored Cross-Site Scripting (XSS) in Activity Feed","id":"CVE-2025-52485"},"packages":[{"ecosystem":"crates.io","fixed":["2.0.4"],"introduced":["2.0.0"],"last_affected":[],"package":"risc0-circuit-rv32im","purl":null,"source":"GHSA-g3qg-6746-3mg9"},{"ecosystem":"crates.io","fixed":["2.0.4"],"introduced":["2.0.0"],"last_affected":[],"package":"risc0-circuit-rv32im","purl":"pkg:cargo/risc0-circuit-rv32im","source":"GHSA-g3qg-6746-3mg9"},{"ecosystem":"crates.io","fixed":["2.1.0"],"introduced":["2.0.0"],"last_affected":[],"package":"risc0-zkvm","purl":null,"source":"GHSA-g3qg-6746-3mg9"},{"ecosystem":"crates.io","fixed":["2.1.0"],"introduced":["2.0.0"],"last_affected":[],"package":"risc0-zkvm","purl":"pkg:cargo/risc0-zkvm","source":"GHSA-g3qg-6746-3mg9"}],"prev":{"headline":"Registrator.jl Vulnerable to Argument Injection and Command Injection","id":"CVE-2025-52483"},"products":["risc0"],"published":"2025-06-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-06-23","vendors":["risc0"]},"summary":"A malicious prover can bypass verification constraints in the RISC Zero zkVM library, allowing invalid proofs to be accepted as valid.","url":"https://insights.sbomify.com/CVE-2025-52484/"}