# CVE-2025-52488: DNN.PLATFORM leaks NTLM hash via SMB Share Interaction with malicious user input

> Attackers can force DNN to leak NTLM hashes to a malicious SMB server via crafted input, exposing credentials.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Jun 2025
- **Updated:** 23 Jun 2025
- **Also known as:** GHSA-mgfv-2362-jq96

## What is CVE-2025-52488?

CVE-2025-52488 is a high-severity vulnerability in Dnnsoftware Dotnetnuke, published on 21 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

DNN (formerly DotNetNuke) is an open-source web content management platform (CMS) in the Microsoft ecosystem. In versions 6.0.0 to before 10.0.1, DNN.PLATFORM allows a specially crafted series of malicious interaction to potentially expose NTLM hashes to a third party SMB server. This issue has been patched in version 10.0.1.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2025-52488?

2 open source packages ship an affected version, including DNN.PLATFORM. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `DNN.PLATFORM` | NuGet | From 6.0.0 | 10.0.1 |
| `DNN.PLATFORM` | NuGet | From 6.0.0 | 10.0.1 |

Products: Dnnsoftware Dotnetnuke.

## How do I fix CVE-2025-52488?

Upgrade DNN.PLATFORM to 10.0.1 or later.

## Is CVE-2025-52488 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-52488 exists.

Public exploit code:

- This exploit targets a vulnerability in DNN (formerly DotNetNuke) versions 6.0.0 to before 10.0.1 that allows attackers to disclose NTLM hashes through Unicode path normalization attacks. (github_poc): https://github.com/sh4den/CVE-2025-52488
- DNN (DotNetNuke) - Unicode Path Normalization NTLM Hash Disclosure (nuclei): http/cves/2025/CVE-2025-52488.yaml

## Other vulnerabilities in Dnnsoftware Dotnetnuke

- [CVE-2017-9822](https://insights.sbomify.com/CVE-2017-9822/): DotNetNuke (DNN) Remote Code Execution (high 8.8, exploited in the wild)
- [CVE-2018-15811](https://insights.sbomify.com/CVE-2018-15811/): DotNetNuke (DNN) Inadequate Encryption Strength (high 7.5, exploited in the wild)
- [CVE-2018-18325](https://insights.sbomify.com/CVE-2018-18325/): DotNetNuke (DNN) Inadequate Encryption Strength (high 7.5, exploited in the wild)
- [CVE-2025-64095](https://insights.sbomify.com/CVE-2025-64095/): DNN Insufficient Access Control - Image Upload allows for Site Content Overwrite (critical 10.0)
- [CVE-2006-3601](https://insights.sbomify.com/CVE-2006-3601/): Privilege escalation in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-52488 and fix it if it is affected.

What it is: CVE-2025-52488 is a high-severity vulnerability in Dnnsoftware Dotnetnuke, published on 21 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-52488 exists.

Affected packages and fixed versions:
- DNN.PLATFORM (NuGet): affected from 6.0.0; fixed in 10.0.1
- DNN.PLATFORM (NuGet): affected from 6.0.0; fixed in 10.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-52488/ (Markdown: https://insights.sbomify.com/CVE-2025-52488/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-52488
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-52488
- OSV: https://osv.dev/vulnerability/CVE-2025-52488

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-52488/
Summaries are generated and may contain mistakes; the official description above is the record.
