CVE-2025-52520 Apache Tomcat: DoS via integer overflow in multipart file upload
An integer overflow in Apache Tomcat allows attackers to bypass size limits and cause denial of service in specific multipart upload configurations.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-52520?
CVE-2025-52520 is a high-severity vulnerability in Apache Tomcat, published on 10 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
For some unlikely configurations of multipart upload, an Integer Overflow vulnerability in Apache Tomcat could lead to a DoS via bypassing of size limits.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.8, from 10.1.0-M1 through 10.1.42, from 9.0.0.M1 through 9.0.106. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 through 8.5.100. Other, older, EOL versions may also be affected.
Users are recommended to upgrade to version 11.0.9, 10.1.43 or 9.0.107, which fix the issue.
Weakness: CWE-190
Which versions are affected by CVE-2025-52520?
17 open source packages ship an affected version, including org.apache.tomcat.embed:tomcat-embed-core, tomcat and org.apache.tomcat:tomcat-catalina. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.tomcat.embed:tomcat-embed-core Maven | From 10.1.0-M1 | 10.1.43 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 10.1.0-M1 | 10.1.43 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 11.0.0-M1 | 11.0.9 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 11.0.0-M1 | 11.0.9 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 8.5.0 to 8.5.100 | None |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 8.5.0 to 8.5.100 | None |
11 more packages
org.apache.tomcat.embed:tomcat-embed-core Maven | From 9.0.0.M1 | 9.0.107 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 9.0.0.M1 | 9.0.107 |
tomcat Bitnami | All versions | 9.0.107, 10.1.43, 11.0.9 |
org.apache.tomcat:tomcat-catalina Maven | From 10.1.0-M1 | 10.1.43 |
org.apache.tomcat:tomcat-catalina Maven | From 10.1.0-M1 | 10.1.43 |
org.apache.tomcat:tomcat-catalina Maven | From 11.0.0-M1 | 11.0.9 |
org.apache.tomcat:tomcat-catalina Maven | From 11.0.0-M1 | 11.0.9 |
org.apache.tomcat:tomcat-catalina Maven | From 8.5.0 to 8.5.100 | None |
org.apache.tomcat:tomcat-catalina Maven | From 8.5.0 to 8.5.100 | None |
org.apache.tomcat:tomcat-catalina Maven | From 9.0.0.M1 | 9.0.107 |
org.apache.tomcat:tomcat-catalina Maven | From 9.0.0.M1 | 9.0.107 |
Products include Apache Tomcat.
How do I fix CVE-2025-52520?
Upgrade org.apache.tomcat.embed:tomcat-embed-core to a fixed version for your release line: 10.1.43, 11.0.9 or 9.0.107.
Is CVE-2025-52520 being exploited?
There is no known exploitation of CVE-2025-52520 in the wild and no public exploit code.
Other vulnerabilities in Apache Tomcat
Sources
Also known as BIT-tomcat-2025-52520, DEBIAN-CVE-2025-52520, GHSA-wr62-c79q-cv37, ROOT-APP-MAVEN-CVE-2025-52520, UBUNTU-CVE-2025-52520.