{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-52552 exists.","fix":"No fix has been published for CVE-2025-52552 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-52552 is a medium-severity cross-site scripting vulnerability in labring FastGPT, published on 21 Jun 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-52552 and fix it if it is affected.\n\nWhat it is: CVE-2025-52552 is a medium-severity cross-site scripting vulnerability in labring FastGPT, published on 21 Jun 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-52552 exists.\n\nAffected product: labring FastGPT. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-52552/ (Markdown: https://insights.sbomify.com/CVE-2025-52552/index.md)","id":"CVE-2025-52552","markdown":"https://insights.sbomify.com/CVE-2025-52552/index.md","name":"CVE-2025-52552","record":{"aliases":["GHSA-r976-rfrv-q24m"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"AI Agent Platform","requires_auth":"none","summary":"Attackers can execute malicious scripts or redirect users via the LastRoute parameter on the login page of FastGPT.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"fastgpt","vendor":"fastgpt"}],"cvss":{"score":5.5,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"},{"id":"CWE-601","name":"URL Redirection to Untrusted Site"}],"description":"FastGPT is an AI Agent building platform. Prior to version 4.9.12, the LastRoute Parameter on login page is vulnerable to open redirect and DOM-based XSS. Improper validation and lack of sanitization of this parameter allows attackers execute malicious JavaScript or redirect them to attacker-controlled sites. This issue has been patched in version 4.9.12.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"FastGPT LastRoute Parameter on Login Page Vulnerable to Open Redirect and DOM-based XSS","id":"CVE-2025-52552","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2025"},"n_packages":0,"n_references":2,"next":{"headline":"authentik has Insufficient Session verification for Remote Access Control endpoint access","id":"CVE-2025-52553"},"packages":[],"prev":{"headline":"Proprietary protocol allows for unauthenticated file operations","id":"CVE-2025-52551"},"products":["FastGPT"],"published":"2025-06-21","related":[{"cvss_score":10,"headline":"FastGPT: Unauthenticated SSRF via httpTools Endpoint Leads to Internal API Key Theft","id":"CVE-2026-34162","kev_date_added":null,"published":"2026-03-31"},{"cvss_score":9.8,"headline":"FastGPT: NoSQL Injection in loginByPassword leads to Authentication Bypass","id":"CVE-2026-40351","kev_date_added":null,"published":"2026-04-17"},{"cvss_score":9.4,"headline":"FastGPT has Arbitrary Code Execution in GitHub Actions via pull_request_target in fastgpt-preview-image.yml","id":"CVE-2026-33075","kev_date_added":null,"published":"2026-03-20"},{"cvss_score":8.8,"headline":"FastGPT: NoSQL Injection in updatePasswordByOld Leads to Account Takeover","id":"CVE-2026-40352","kev_date_added":null,"published":"2026-04-17"},{"cvss_score":7.7,"headline":"Server-Side Request Forgery via MCP Tools Endpoint in FastGPT","id":"CVE-2026-34163","kev_date_added":null,"published":"2026-03-31"},{"cvss_score":6.9,"headline":"Cross-Site Request Forgery (CSRF) in FastGPT","id":"CVE-2026-26075","kev_date_added":null,"published":"2026-02-12"},{"cvss_score":6.9,"headline":"FastGPT Plugin forwarding request is not authenticated, posing a serious risk of attack","id":"CVE-2026-26003","kev_date_added":null,"published":"2026-02-10"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-06-23","vendors":["labring"]},"summary":"Attackers can execute malicious scripts or redirect users via the LastRoute parameter on the login page of FastGPT.","url":"https://insights.sbomify.com/CVE-2025-52552/"}