# CVE-2025-52553: authentik has Insufficient Session verification for Remote Access Control endpoint access

> Attackers can hijack remote access sessions by reusing tokens, allowing unauthorized access to user sessions in authentik.

- **Severity:** Medium 5.5 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Jun 2025
- **Updated:** 27 Jun 2025
- **Also known as:** BIT-authentik-2025-52553, GHSA-wr3v-9p2c-chx7

## What is CVE-2025-52553?

CVE-2025-52553 is a medium-severity authentication bypass vulnerability in goauthentik authentik, published on 27 Jun 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

authentik is an open-source identity provider. After authorizing access to a RAC endpoint, authentik creates a token which is used for a single connection and is sent to the client in the URL. This token is intended to only be valid for the session of the user who authorized the connection, however this check is missing in versions prior to 2025.6.3 and 2025.4.3. When, for example, using RAC during a screenshare, a malicious user could access the same session by copying the URL from the shown browser. authentik 2025.4.3 and 2025.6.3 fix this issue. As a workaround, it is recommended to decrease the duration a token is valid for (in the RAC Provider settings, set Connection expiry to `minutes=5` for example). The maintainers of authentik also recommend enabling the option Delete authorization on disconnect.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2025-52553?

1 open source package ship an affected version, including authentik. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `authentik` | Bitnami | All versions | 2025.4.3, 2025.6.3 |

Products: Goauthentik Authentik.

## How do I fix CVE-2025-52553?

Upgrade authentik to a fixed version for your release line: 2025.4.3 or 2025.6.3.

## Is CVE-2025-52553 being exploited?

There is no known exploitation of CVE-2025-52553 in the wild and no public exploit code.

## Other vulnerabilities in goauthentik authentik

- [CVE-2026-49448](https://insights.sbomify.com/CVE-2026-49448/): authentik: SourceStage bypass via empty POST (critical 9.8)
- [CVE-2023-46249](https://insights.sbomify.com/CVE-2023-46249/): authentik potential installation takeover when default admin user is deleted (critical 9.7)
- [CVE-2022-23555](https://insights.sbomify.com/CVE-2022-23555/): authentik vulnerable to Improper Authentication via invitation URL token reuse (critical 9.4)
- [CVE-2026-42849](https://insights.sbomify.com/CVE-2026-42849/): authentik: Reflected XSS in SFE AutosubmitStage allows IDP account takeover (critical 9.3)
- [CVE-2026-25227](https://insights.sbomify.com/CVE-2026-25227/): authentik affected by Remote Code Execution via Context Key Injection in PropertyMapping Test Endpoint (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-52553 and fix it if it is affected.

What it is: CVE-2025-52553 is a medium-severity authentication bypass vulnerability in goauthentik authentik, published on 27 Jun 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-52553 in the wild and no public exploit code.

Affected packages and fixed versions:
- authentik (Bitnami): affected all versions; fixed in 2025.4.3, 2025.6.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-52553/ (Markdown: https://insights.sbomify.com/CVE-2025-52553/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-52553
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-52553
- OSV: https://osv.dev/vulnerability/CVE-2025-52553

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-52553/
Summaries are generated and may contain mistakes; the official description above is the record.
