{"answers":{"affected":"1 open source package ship an affected version, including ceph.","exploited":"There is no known exploitation of CVE-2025-52555 in the wild and no public exploit code.","fix":"Upgrade ceph to a fixed version for your release line: 17.2.8, 18.2.5 or 19.2.3.","what":"CVE-2025-52555 is a medium-severity vulnerability in ceph, published on 26 Jun 2025. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-52555 and fix it if it is affected.\n\nWhat it is: CVE-2025-52555 is a medium-severity vulnerability in ceph, published on 26 Jun 2025. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-52555 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ceph (Bitnami): affected from 17.2.7; fixed in 17.2.8, 18.2.5, 19.2.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-52555/ (Markdown: https://insights.sbomify.com/CVE-2025-52555/index.md)","id":"CVE-2025-52555","markdown":"https://insights.sbomify.com/CVE-2025-52555/index.md","name":"CVE-2025-52555","record":{"aliases":["AZL-64386","BIT-ceph-2025-52555","DEBIAN-CVE-2025-52555","ECHO-096d-8796-1abe","GHSA-89hm-qq33-2fjm","MGASA-2025-0222","OESA-2025-1838","OESA-2025-1902","OESA-2025-1903"],"analysis":{"component_type":"operating_system","fix_type":"patch","impacts":["privilege_escalation","data_read","data_modify"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Ceph distributed storage","requires_auth":"low_privilege","summary":"An unprivileged user can escalate to root privileges in a ceph-fuse mounted CephFS by changing directory permissions, allowing full access to root-owned files.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:A/AC:H/PR:L/UI:N/S:C/C:H/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-269","name":"Improper Privilege Management"}],"description":"Ceph is a distributed object, block, and file storage platform. In versions 17.2.7, 18.2.1 through 18.2.4, and 19.0.0 through 19.2.2, an unprivileged user can escalate to root privileges in a ceph-fuse mounted CephFS by chmod 777 a directory owned by root to gain access. The result of this is that a user could read, write and execute to any directory owned by root as long as they chmod 777 it. This impacts confidentiality, integrity, and availability. It is patched in versions 17.2.8, 18.2.5, and 19.2.3.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"CephFS Permission Escalation Vulnerability in Ceph Fuse mounted FS","id":"CVE-2025-52555","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"privilege_escalation","year":"2025"},"n_packages":1,"n_references":2,"next":{"headline":"rfc3161-client has insufficient verification for timestamp response signatures","id":"CVE-2025-52556"},"packages":[{"ecosystem":"Bitnami","fixed":["17.2.8","18.2.5","19.2.3"],"introduced":["17.2.7","18.2.1","19.0.0"],"last_affected":[],"package":"ceph","purl":"pkg:bitnami/ceph","source":"BIT-ceph-2025-52555"}],"prev":{"headline":"n8n Improper Authorization in Workflow Execution Stop Endpoint Allows Terminating Other Users’ Workflows","id":"CVE-2025-52554"},"products":["ceph"],"published":"2025-06-26","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-03","vendors":["ceph"]},"summary":"An unprivileged user can escalate to root privileges in a ceph-fuse mounted CephFS by changing directory permissions, allowing full access to root-owned files.","url":"https://insights.sbomify.com/CVE-2025-52555/"}