# CVE-2025-52556: rfc3161-client has insufficient verification for timestamp response signatures

> Attackers can bypass timestamp response signature verification by providing arbitrary signatures, undermining trust in time-stamped data.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Jun 2025
- **Updated:** 23 Jun 2025
- **Also known as:** GHSA-6qhv-4h7r-2g9m, PYSEC-2026-525, openSUSE-SU-2025:15282-1

## What is CVE-2025-52556?

CVE-2025-52556 is a critical vulnerability in trailofbits rfc3161-client, published on 21 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

rfc3161-client is a Python library implementing the Time-Stamp Protocol (TSP) described in RFC 3161. Prior to version 1.0.3, there is a flaw in the timestamp response signature verification logic. In particular, chain verification is performed against the TSR's embedded certificates up to the trusted root(s), but fails to verify the TSR's own signature against the timestamping leaf certificates. Consequently, vulnerable versions perform insufficient signature validation to properly consider a TSR verified, as the attacker can introduce any TSR signature so long as the embedded leaf chains up to some root TSA. This issue has been patched in version 1.0.3. There is no workaround for this issue.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2025-52556?

3 open source packages ship an affected version, including rfc3161-client.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rfc3161-client` | PyPI | All versions | 1.0.3 |
| `rfc3161-client` | PyPI | All versions | 1.0.3 |
| `rfc3161-client` | PyPI | All versions | 1.0.3 |
| `python-rfc3161-client` | openSUSE:Tumbleweed | All versions | 1.0.3-1.1 |

## How do I fix CVE-2025-52556?

Upgrade rfc3161-client to 1.0.3 or later.

## Is CVE-2025-52556 being exploited?

There is no known exploitation of CVE-2025-52556 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-52556 and fix it if it is affected.

What it is: CVE-2025-52556 is a critical vulnerability in trailofbits rfc3161-client, published on 21 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-52556 in the wild and no public exploit code.

Affected packages and fixed versions:
- rfc3161-client (PyPI): affected all versions; fixed in 1.0.3
- rfc3161-client (PyPI): affected all versions; fixed in 1.0.3
- rfc3161-client (PyPI): affected all versions; fixed in 1.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-52556/ (Markdown: https://insights.sbomify.com/CVE-2025-52556/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-52556
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-52556
- OSV: https://osv.dev/vulnerability/CVE-2025-52556

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-52556/
Summaries are generated and may contain mistakes; the official description above is the record.
