# CVE-2025-52558: ChangeDetection.io XSS in watch overview

> An XSS vulnerability in changedetection.io allows attackers to inject scripts via unfiltered watch errors, potentially compromising user sessions.

- **Severity:** High 7.0 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:L/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Jun 2025
- **Updated:** 24 Jun 2025
- **Also known as:** GHSA-hwpg-x5hw-vpv9, PYSEC-2026-1241

## What is CVE-2025-52558?

CVE-2025-52558 is a high-severity cross-site scripting vulnerability in dgtlmoon changedetection.io, published on 23 Jun 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

changedetection.io is a free open source web page change detection, website watcher, restock monitor and notification service. Prior to version 0.50.4, errors in filters from website page change detection watches were not being filtered resulting in a cross-site scripting (XSS) vulnerability. This issue has been patched in version 0.50.4

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-52558?

3 open source packages ship an affected version, including changedetection.io and changedetection-io.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `changedetection.io` | PyPI | All versions | 0.50.4 |
| `changedetection-io` | PyPI | All versions | 0.50.4 |
| `changedetection-io` | PyPI | All versions | 0.50.4 |

## How do I fix CVE-2025-52558?

Upgrade changedetection.io to 0.50.4 or later.

## Is CVE-2025-52558 being exploited?

There is no known exploitation of CVE-2025-52558 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-52558 and fix it if it is affected.

What it is: CVE-2025-52558 is a high-severity cross-site scripting vulnerability in dgtlmoon changedetection.io, published on 23 Jun 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-52558 in the wild and no public exploit code.

Affected packages and fixed versions:
- changedetection.io (PyPI): affected all versions; fixed in 0.50.4
- changedetection-io (PyPI): affected all versions; fixed in 0.50.4
- changedetection-io (PyPI): affected all versions; fixed in 0.50.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-52558/ (Markdown: https://insights.sbomify.com/CVE-2025-52558/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-52558
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-52558
- OSV: https://osv.dev/vulnerability/CVE-2025-52558

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-52558/
Summaries are generated and may contain mistakes; the official description above is the record.
