CVE-2025-52562 Convey Panel Directory Traversal in LocaleController leading to Remote Code Execution

Critical 10.0 Published Updated

Unauthenticated attackers can exploit a directory traversal flaw in the LocaleController to execute arbitrary PHP code on the server.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-52562?

CVE-2025-52562 is a critical path traversal vulnerability in ConvoyPanel panel, published on 23 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Convoy is a KVM server management panel for hosting businesses. In versions 3.9.0-rc3 to before 4.4.1, there is a directory traversal vulnerability in the LocaleController component of Performave Convoy. An unauthenticated remote attacker can exploit this vulnerability by sending a specially crafted HTTP request with malicious locale and namespace parameters. This allows the attacker to include and execute arbitrary PHP files on the server. This issue has been patched in version 4.4.1. A temporary workaround involves implementing strict Web Application Firewall (WAF) rules to incoming requests targeting the vulnerable endpoints.

Weakness: CWE-98, CWE-22

Which versions are affected by CVE-2025-52562?

How do I fix CVE-2025-52562?

No fix has been published for CVE-2025-52562 yet. Limit exposure of the affected software until one is available.

Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.

Is CVE-2025-52562 being exploited?

There is no known exploitation of CVE-2025-52562 in the wild and no public exploit code.

Sources

Also known as GHSA-43g3-qpwq-hfgg.

Is CVE-2025-52562 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free