{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2025-52562 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2025-52562 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-52562 is a critical path traversal vulnerability in ConvoyPanel panel, published on 23 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-52562 and fix it if it is affected.\n\nWhat it is: CVE-2025-52562 is a critical path traversal vulnerability in ConvoyPanel panel, published on 23 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-52562 in the wild and no public exploit code.\n\nAffected product: ConvoyPanel panel. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-52562/ (Markdown: https://insights.sbomify.com/CVE-2025-52562/index.md)","id":"CVE-2025-52562","markdown":"https://insights.sbomify.com/CVE-2025-52562/index.md","name":"CVE-2025-52562","record":{"aliases":["GHSA-43g3-qpwq-hfgg"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Convoy KVM panel","requires_auth":"none","summary":"Unauthenticated attackers can exploit a directory traversal flaw in the LocaleController to execute arbitrary PHP code on the server.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":10,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-98","name":"Improper Control of Filename for Include/Require Statement in PHP Program"},{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Convoy is a KVM server management panel for hosting businesses. In versions 3.9.0-rc3 to before 4.4.1, there is a directory traversal vulnerability in the LocaleController component of Performave Convoy. An unauthenticated remote attacker can exploit this vulnerability by sending a specially crafted HTTP request with malicious locale and namespace parameters. This allows the attacker to include and execute arbitrary PHP files on the server. This issue has been patched in version 4.4.1. A temporary workaround involves implementing strict Web Application Firewall (WAF) rules to incoming requests targeting the vulnerable endpoints.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Convey Panel Directory Traversal in LocaleController leading to Remote Code Execution","id":"CVE-2025-52562","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"path_traversal","year":"2025"},"n_packages":0,"n_references":2,"next":{"headline":"Chamilo: Reflected XSS via page parameter","id":"CVE-2025-52563"},"packages":[],"prev":{"headline":"HTMLSanitizer.jl Possible XSS","id":"CVE-2025-52561"},"products":["panel"],"published":"2025-06-23","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-06-24","vendors":["ConvoyPanel"]},"summary":"Unauthenticated attackers can exploit a directory traversal flaw in the LocaleController to execute arbitrary PHP code on the server.","url":"https://insights.sbomify.com/CVE-2025-52562/"}